Configuration Manager clients become inactive and do not send inventory

Symptom
Microsoft System Center Configuration Manager clients that report to a particular server or subset of servers may repeatedly become inactive. You may also notice that the clients do not send inventory information for 30 days or more and that the data in the Inventoryagent.log file is static. Additionally, the ClientIDManagerStartup.log displays repeated occurrences of the following error:

[RegTask] - Client is not registered. Sending registration request for GUID:4874BD6C-CB98-4EEB-9F4F-721CC65B25C3 ...
[RegTask] - Client is registered. Server assigned ClientID is GUID:4874BD6C-CB98-4EEB-9F4F-721CC65B25C3. Approval status 1
SetRegistrationState failed (0x80071770)
[RegTask] - Sleeping for 15360 seconds ...

Note Error code 0x80071770 indicates that the specified file could not be encrypted.
Cause
This is a known issue in cng.sys and is related to the update that is mentioned in the following article in the Microsoft Knowledge Base:
3004375 Microsoft security advisory: Update to improve Windows command-line auditing: February 10, 2015


Resolution
To resolve this issue, apply either update 3023562 or update 3046049 to update your version of cng.sys. After you apply either of these updates and restart the computer, the affected client will successfully send up a heartbeat and update inventory data. This action will also enable the client to remain active.  
Properties

Article ID: 3067633 - Last Review: 06/15/2015 14:54:00 - Revision: 4.0

Microsoft System Center 2012 Configuration Manager, Microsoft System Center 2012 Configuration Manager Service Pack 1, Microsoft System Center 2012 Configuration Manager Service Pack 2, Microsoft System Center 2012 R2 Configuration Manager, Microsoft System Center 2012 R2 Configuration Manager Service Pack 1

  • kbexpertiseadvanced kbtshoot kbsurveynew KB3067633
Feedback