"Updating hybrid configuration fails with 'object not found'" error when you run the Hybrid Configuration Wizard

Note The Hybrid Configuration wizard that's included in the Exchange Management Console in Microsoft Exchange Server 2010 is no longer supported. Therefore, you should no longer use the old Hybrid Configuration wizard. Instead, use the Office 365 Hybrid Configuration wizard that's available at http://aka.ms/HybridWizard. For more information, see Office 365 Hybrid Configuration wizard for Exchange 2010.
PROBLEM
You want to set up a hybrid deployment between your on-premises Microsoft Exchange Server organization and Exchange Online in Office 365. However, when you run the Hybrid Configuration Wizard, the operation fails. Also, you may receive one of the following error messages:
  • Error 1: New-OnPremisesOrganization
    [08/27/2015 13:10:01] INFO : Session=Tenant Cmdlet=New-OnPremisesOrganization FINISH Time=953.1634ms
    [08/27/2015 13:10:01] ERROR : Subtask Configure execution failed: Configure Mail Flow Execution of the New-OnPremisesOrganization cmdlet has thrown an exception. This may indicate invalid parameters in your hybrid configuration settings.
    InboundConnector 'First Organization\Inbound from c5343492-3047-40aa-8b53-46c0b31c5660' doesn't exist. at Microsoft.Exchange.Management.Hybrid.RemotePowershellSession.RunCommand(String cmdlet, SessionParameters parameters, Boolean ignoreNotFoundErrors)
  • Error 2: Set-HybridMailflow (Exchange Server 2010 only)
    [8/28/2015 18:27:17] INFO:Cmdlet: Set-HybridMailflow --Start Time: 8/28/2015 11:27:17 AM.
    [8/28/2015 18:27:18] ERROR:System.Management.Automation.RemoteException: Organization "First Organization" was not found. Please make sure you have typed it correctly.
    [8/28/2015 18:27:18] INFO:Cmdlet: Set-HybridMailflow --End Time: 8/28/2015 11:27:18 AM.
    [8/28/2015 18:27:18] INFO:Cmdlet: Set-HybridMailflow --Processing Time: 374.4048.
    [8/28/2015 18:27:18] INFO:Disconnected from On-Premises session
    [8/28/2015 18:27:18] INFO:Disconnected from Tenant session
    [8/28/2015 18:27:18] ERROR:Updating hybrid configuration failed with error 'Subtask Configure execution failed: Configure Mail Flow
SOLUTION

For error 1

To fix error 1, follow these steps:
  1. Install the latest cumulative update for Exchange Server 2013. To download this update, go to Updates for Exchange 2013.
  2. Run the latest version of the Hybrid Configuration wizard. To download the latest Hybrid Configuration wizard, go to http://aka.ms/TAPHCW.
For more information about the benefits of the latest Hybrid Configuration wizard, see Introducing the Microsoft Office 365 Hybrid Configuration Wizard.

For error 2

There is currently no solution for this problem in Exchange Server 2010. Microsoft is working to deploy a fix in the datacenter for this particular scenario. If you can’t fix this problem on your own, contact Microsoft Support and reference this article.
MORE INFORMATION
Microsoft is researching this problem and will post more information in this article when the information becomes available.

Still need help? Go to the Office 365 Community website or the Exchange TechNet Forums.
Properties

Article ID: 3093284 - Last Review: 04/26/2016 14:58:00 - Revision: 6.0

Microsoft Exchange Online, Microsoft Exchange Server 2013 Enterprise, Microsoft Exchange Server 2013 Standard, Microsoft Exchange Server 2010 Enterprise, Microsoft Exchange Server 2010 Standard

  • o365e o365m o365022013 o365 o365a hybrid KB3093284
Feedback