Storage account setting is blank in Azure Site Recovery

Original product version:   Azure Backup
Original KB number:   3093586

Symptoms

When you try to configure protection group settings in Microsoft Azure Site Recovery, the Storage Account list may be blank. This issue prevents the wizard from being able to finish.

Screenshot of specifying Protection Group Settings in Microsoft Azure Site Recover.

The setup process is described in the following article: Set up protection between on-premises VMware virtual machines or physical servers and Azure.

Cause

This error may occur if the storage account isn't configured to be geo-redundant. Storage accounts are geo-redundant by default. You can manually disable geo-redundancy during account setup.

Resolution

To fix this issue, follow these steps:

  1. Cancel the Create Protection Group wizard.
  2. Either create a new storage account or change the replication setting to geo redundant. This setting is located under the storage account settings properties on the Configure tab in the Azure portal.
  3. Click Save to commit the change.
  4. Restart the Create Protection Group wizard.

Contact us for help

If you have questions or need help, create a support request, or ask Azure community support. You can also submit product feedback to Azure feedback community.