"This file cannot be previewed because there is no previewer installed for it" error when you preview Excel workbooks in Outlook 2016

Symptoms
In Outlook 2016, when you select a Microsoft Excel workbook that is attached to an email to preview the workbook, you may receive the following error message.

This file cannot be previewed because there is no previewer installed for it.


Cause
This issue occurs because there is incorrect data in the registry that is related to the Excel previewer.
Resolution
To fix this issue for an MSI-based installation, install the December 8, 2015, update for Excel 2016. For information about this update, click the following article number to view the article in the Microsoft Knowledge Base:

3114374 December 8, 2015, update for Excel 2016 (KB3114374)

To fix this issue for a Click-to-Run installation, make sure that your Office 2016 Click-to-Run installation is updated to the latest version. To update your Office 2016 Click-to-Run installation, follow these steps.
  1. Open any Office application, such as Outlook or Word.
  2. Click File, and then click Office Account or Account
  3. Click Update Options, and then click Update Now.

Note
 If you have installed these updates and the issue persists, follow the steps in the "Workaround" section.

To determine whether you're using a Click-to-Run or MSI installation, see the "More Information" section.
Workaround
Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.


If you can't install the update that's mentioned in the "Resolution" section, you can work around the issue by following these steps:

  1. Exit Outlook.
  2. Start Registry Editor. To do this, use one of the following procedures, as appropriate for your version of Windows:
    • In Windows 10, Windows 8.1, and Windows 8, press the Windows key + R to open a Run dialog box, type regedit.exe, and then click OK.
    • In Windows 7, click Start, type regedit.exe in the search box, and then press Enter.
  3. Locate and then select one of the following registry keys, depending on the type and bitness of the products that you are using:

    • For a Click-to-Run installation of any bitness of Outlook and Windows, locate and then select the following registry key:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\Software\Microsoft\Windows\CurrentVersion\PreviewHandlers
    • For an MSI installation of 32-bit Outlook on 64-bit Windows, locate and then select the following registry key:

      HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\PreviewHandlers
    • For an MSI installation of 32-bit Outlook on 32-bit Windows or 64-bit Outlook on 64-bit Windows, locate and then select the following registry key:

      HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\PreviewHandlers
  4. Locate the value that has the following name, and then view its Type:

    {00020827-0000-0000-C000-000000000046}

    Note Depending on whether this value exists and what its Type is, take one of the following actions:

    • If the Type is anything other than REG_SZ, go to step 5.
    • If the Type is REG_SZ, go to step 8.
    • If this value does not exist, go to step 6.

  5. Right-click the {00020827-0000-0000-C000-000000000046} value, select Delete, and then click Yes to confirm the deletion.
  6. On the Edit menu, select New, and then click String Value.
  7. Type the following text, and then press Enter.

    {00020827-0000-0000-C000-000000000046}
  8. Right-click {00020827-0000-0000-C000-000000000046}, and then click Modify.
  9. In the Value data box, type the following text, and then click OK.

    Microsoft Excel previewer
  10. On the File menu, click Exit to exit Registry Editor.

More information

How to determine whether you are using a Click-to-Run or MSI installation

On the File tab in Outlook, click Office Account.

Click-to-Run installation

If you see Office Updates in the Product Information area, you have a Click-to-Run installation of Office 2016.

If you do not see Office Updates in the Product Information area, you have an MSIinstallation of Office 2016.


Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
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Article ID: 3100511 - Last Review: 01/21/2016 22:14:00 - Revision: 9.0

Outlook 2016

  • KB3100511
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