Issues after Exchange Server upgrade if the arbitration mailbox isn't upgraded to the new Exchange server

Original KB number:   3108541

Symptoms

After you install a new version of Exchange Server, you experience one or more of the following issues:

  • eDiscovery searches for new or moved mailboxes do not work.
  • Mailbox moves stall or are not completed successfully.
  • Audit report messages are not generated for new or moved mailboxes.
  • Daily Skype for Business call logs for new or moved mailboxes are blank.

Cause

This issue occurs if the arbitration mailbox that's used for the process is still hosted on an older version of Exchange Server.

Resolution

To resolve this issue, move the arbitration mailbox to the latest version of Exchange Server in the environment.

To do this, first run the following Get-Mailbox cmdlet to locate the arbitration mailbox:

Get-Mailbox -Arbitration

Run the following New-MoveRequest cmdlet to move the mailbox:

Get-Mailbox -Arbitration | New-MoveRequest -TargetDatabase <name>