VM cloud doesn't load when the admin portal is accessed on a Windows Azure Pack server

Symptoms
Consider the following scenario:
  • Windows Azure Pack (WAP) is installed on two servers by using express installation (WAP1 and WAP2). The two WAP servers are load balanced.
  • Service Provider Foundation (SPF) is installed on two servers (SPF1 and SPF2). The two SPF servers are load balanced.
  • A virtual machine (VM) cloud is successfully registered.

In this scenario, the VM cloud doesn't load when the admin portal is accessed on the WAP2 server. However, the VM cloud can be successfully loaded without errors when it is accessed through the admin portal on the WAP1 server.

You may also see the following exception on either SPF server:

Log Name: Microsoft-ServiceProviderFoundation/Analytic
Source: Microsoft-ServiceProviderFoundation
Date: Event ID: 11
Task Category: (65523)
Level: Error
Keywords: None
User: S-1-5-21-3138815620-4253048750-3916773603-117721
Computer: Description:
Component: VMMActivity [Powershell::Invoke, id {21C04886-019D-49EA-989B-916B44B6D9AB}]
Parent activity [Get, id {1EFAC67B-981A-4764-9BE6-0D2FCD887E43}]Elapsed: 169ms
Context: {70BAB268-8316-4FC7-B28B-821C9192BC4C}Error when aggregating resources. Cannot query resources on stamp VMMServerName.Contoso.com Reason: The connection to the VMM management server VMMserverName.Contoso.com was lost. (Error ID: 1610)

Ensure that VMMServerName.Contoso.com is online and that you can access the server remotely from your computer. Then connect to VMMServerName.Contoso.com and try the command again using the new connection. Or, you can ensure that the Virtual Machine Manager service is started on VMMServerName.Contoso.com. Then connect to VMMServerName.Contoso.com and try the command again using the new connection. If the command fails again because of a connection failure, restart the Virtual Manager service and then try the operation again.
Cause
This problem can occur if the IndigoTCPPort registry value on either SPF server is missing.
Resolution
To fix this issue, follow these steps: 
  1. Stop the SPF Web Service on the SPF2 server.
  2. Access the admin portal from both WAP1 and WAP2 servers. This forces all connections from the WAP service management layer to go to the SPF2 server. Be aware that, although at first you can't load the VM cloud information when you access the portal from the WAP2 server, after the SPF Web Service is stopped on the SPF2 server, the VM cloud can be loaded successfully in the admin portal on both WAP servers.
  3. Examine the following registry location on both SPF servers:

    HKLM\Software\Microsoft\Microsoft System Center Virtual Machine Manager Administrator Console\Settings


    Check whether the IndigoTCPPort value is missing on the SPF2 server, and that it matches the value on SPF1.
  4. If the IndigoTCPPort registry value is missing, create it so that it matches on both SPF servers.
  5. Start the SPF Web Service on the SPF2 server.

The VM clouds can be loaded successfully by using the admin portal on both WAP servers.

VMM 2012 R2 SCVMM 2012 R2
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
Properties

Article ID: 3110311 - Last Review: 11/17/2015 20:33:00 - Revision: 3.0

Windows Azure Pack, Microsoft System Center 2012 Virtual Machine Manager, Microsoft System Center 2012 R2 Virtual Machine Manager

  • kbexpertiseadvanced kbsurveynew kbtshoot KB3110311
Feedback