Your Computer Hangs When You Log On to a Terminal Services Session

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

This article has been archived. It is offered "as is" and will no longer be updated.
Symptoms
When you log on to a Terminal Services session, your computer may stop responding (hang) while your user settings are being loaded. If you log on to the local computer, you may receive the following Stop error message:
C000021A (STATUS_SYSTEM_PROCESS_TERMINATED)
Cause
This problem can be caused by an incorrect registry value.
Resolution

Windows 2000

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in theMicrosoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this fix should have the following file attributes or later:
Date         Time   Version        Size       File name----------------------------------------------------------06-Nov-2001  12:48  5.0.2195.4572    222,480  Gdi32.dll06-Nov-2001  12:48  5.0.2195.4272    731,920  Kernel32.dll25-Jun-2001  18:17  3.10.0.103        47,808  User.exe06-Nov-2001  12:48  5.0.2195.4314    402,192  User32.dll06-Nov-2001  12:48  5.0.2195.4345    371,984  Userenv.dll27-Sep-2001  15:00  5.0.2195.4426  1,731,536  Win32k.sys30-Oct-2001  18:17  5.0.2195.4575    178,960  Winlogon.exe06-Nov-2001  12:48  5.0.2195.4602    243,472  Winsrv.dll					

Status

Windows XP

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article.

Windows 2000

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 3.
More information
For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:
296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot
For additional information about how to install Windows 2000 and Windows 2000 hotfixes at the same time, click the article number below to view the article in the Microsoft Knowledge Base:
249149 Installing Microsoft Windows 2000 and Windows 2000 Hotfixes
kbShell
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
Properties

Article ID: 311804 - Last Review: 01/12/2015 19:11:31 - Revision: 1.0

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • kbnosurvey kbarchive kbautohotfix kbHotfixServer kbqfe kbbug kbfix kbshell kbwin2000presp3fix kbwin2000sp3fix KB311804
Feedback