Document IDs aren't assigned to items in a document library in SharePoint Online

PROBLEM
Consider the following scenario:
  • You have multiple custom content types that are based on a document content type. These custom content types are published from a content type hub site collection to subscriber site collections.
  • On a subscriber site collection, you set one of the custom content types as the default content type on a document library.
  • You enable the Document ID Service feature on the site collection.
When you go to the site collection and then view a document in a document library, the document IDs aren't assigned, and the document ID column isn't displayed as a column in a view.
SOLUTION
To enable the Document ID Service feature on a site collection that's subscribed to the content type hub, you must first enable the Document ID Service feature on the content type hub site collection. Then, you must republish syndicated content types so that the subscriber site collections can update their site content types.

For more information about how to publish a content type from a content type publishing hub, see the following article: 
MORE INFORMATION
This issue occurs because a site content type that's published to a subscriber site collection is set to read-only when a content type hub publishes a content type. This occurs regardless of whether the content type that's defined on the content type hub is read-only. When the Document ID Service feature is enabled on the subscriber site collection, required columns are missing and cannot be provisioned because the site content type is read-only.

For more information about how to enable site collection features, see the following article:  
Still need help? Go to the Office 365 Community website.
Properties

Article ID: 3125194 - Last Review: 12/14/2015 23:14:00 - Revision: 1.0

Microsoft SharePoint Online

  • o365 o365e o365p o365a o365m o365022013 KB3125194
Feedback