Clarification of the applicability of updates for the .NET Framework 4.6 and 4.6.1

Summary

Microsoft has received several questions from valued customers about the applicability of the Microsoft .NET Framework 4.6 and the Microsoft .NET Framework 4.6.1 security updates. The .NET Framework 4.6 and 4.6.1 updates are intended to be installed on systems that have only the .NET Framework 4.6 or 4.6.1 products previously installed. Installing a security update for the .NET Framework 4.6 and 4.6.1 on a system that has an earlier version of the .NET Framework installed is unsupported and causes functionality problems. Enterprise customers should continue to rely only on Microsoft Update applicability management for enterprise security update deployments. 

Guidance

The applicability of the .NET Framework 4.6 and 4.6.1 is determined by the following guidelines:

  • Windows Update (WU) and Windows Server Update Services (WSUS) customers do not have to make any procedural changes. Customers on WU and WSUS should continue to rely on Microsoft Update (MU) to determine the applicability of security updates. Microsoft Update will automatically offer only the .NET Framework 4.6 and 4.6.1 updates to customers who have the .NET Framework 4.6 or 4.6.1 on their systems. These updates will not be offered on any system that has an earlier .NET Framework version installed.
  • Customers who use Microsoft System Center Configuration Manager or any similar deployment environments should also continue to rely on Microsoft Update to determine the applicability of the .NET Framework security updates. 
  • Customers who use System Center Configuration Manager or any similar deployment environments but who, for any reason, absolutely cannot rely on the provided Microsoft Update applicability information to create and manage custom deployments should refrain from deploying the .NET Framework 4.6 and 4.6.1 security updates to target systems that contain earlier versions of the .NET Framework.
  • Individual customers should refrain from manually installing the .NET Framework 4.6 and 4.6.1 security updates on systems that have any version earlier than the .NET Framework 4.6 installed.
  • We ask that you rely on Microsoft documentation for the .NET Framework updates. Security update bulletins, the Microsoft Download Center, and the Microsoft Knowledge Base (KB) articles all describe which versions of the Microsoft .NET Framework an update is intended to be applied to.
  • Generally, customers on any given version of the .NET Framework should install only updates that apply to the target version of the .NET Framework that is installed on their system. Update installations that are intended for either a later version or an earlier version of the .NET Framework may not be blocked even though such an installation is unsupported. This unsupported state can be expected to cause functionality problems.
  • For help to determine which .NET Framework version is installed on your system, see How to: Determine Which .NET Framework Versions Are Installed.

Mitigation

If a security update for the .NET Framework 4.6 and 4.6.1 was installed on a system that does not have the .NET Framework 4.6 or the .NET Framework 4.6.1 installed, you should immediately uninstall the security update for the unsupported configuration, and then run Microsoft Update or go to the Microsoft Download Center for the appropriate security update content for the .NET Framework 4.6 and 4.6.1. 
Properties

Article ID: 3136092 - Last Review: 01/15/2016 01:05:00 - Revision: 1.0

Microsoft .NET Framework 4.5, Microsoft .NET Framework 4.5.1, Microsoft .NET Framework 4.5.2, Microsoft .NET Framework 4.6, Microsoft .NET Framework 4.6.1

  • kbqfe kbsurveynew KB3136092
Feedback