Outlook crashes when you attempt to track an email in Microsoft Dynamics CRM

Symptoms
When you click Track in CRM or Set Regarding on an email with an attachment, Microsoft Outlook crashes. 

Additionally, in the Application Event log, you may find one or more of the following crash signatures with event ID 1000:

Application nameApplication versionModule nameModule versionOffset
Outlook 2010
Outlook.exe14.0.7165.5000exsec32.dll14.0.7159.50000x00007D06
Outlook.exe14.0.7160.5000exsec32.dll14.0.7159.50000x00000000000023C5
Outlook.exe14.0.6109.5005exsec32.dll14.0.6019.10000x00007C50
Outlook 2013
Outlook.exe15.0.4763.1000exsec32.dll15.0.4759.10000x000076BD
Outlook.exe15.0.4551.1004exsec32.dll15.0.4551.10010x000076a7
Outlook 2016
Outlook.exe16.0.6366.2036exsec32.dll16.0.6366.14390x00003F99
Outlook.exe16.0.4266.1001exsec32.dll16.0.4266.10010x00003F82
Outlook.exe16.0.4266.1001exsec32.dll16.0.4266.10010x000000000000251F


Cause
This issue can occur if Outlook is not configured to use Cached Exchange Mode. Microsoft Dynamics CRM for Outlook is only supported when using Cached Exchange Mode.


Resolution
To fix this issue, follow the steps for your Office version and installation type. See the 'More Information' section to determine whether your Office installation is Click-to-Run or MSI-based.


Office 2016:

Click-to-Run-based Installations:
To fix this issue, make sure that your Office 2016 Click-to-Run installation is at version 16.0.6629.1000 or a later version. If it is not at this version or a later version, update your Office 2013 installation. To do this, follow these steps. 

  1. Open any Office application, such as Outlook or Word.
  2. Click File, and then click Office Account or Account.
  3. View the Version that is listed under Office Updates.
  4. If the version is not at 16.0.6629.1000 or a later version, click Update Options, and then click Update Now.

    Note If you had previously disabled updates, click Enable updates after you click Update Options, and then click Update Now.

For more information about update channels for Office 365 clients, see the following article: Version numbers of update channels for Office 365 clients.


MSI-based Installations:

Microsoft is researching this problem for Office 2016 MSI-based installations, and will post more information in this article when the information becomes available.


Office 2013:

Click-to-Run based Installations:
To fix this issue, make sure that your Office 2013 Click-to-Run installation is at version 15.0.4833.1001 or a later version. If it is not at this version or a later version, update your Office 2013 installation. To do this, follow these steps. 

  1. Open any Office application, such as Outlook or Word.
  2. Click File, and then click Office Account or Account.
  3. View the Version that is listed under Office Updates.
  4. If the version is not at 15.0.4833.1001 or a later version, click Update Options, and then click Update Now.

    Note If you had previously disabled updates, click Enable updates after you click Update Options, and then click Update Now.

For more information about Click-to-Run for Office 2013, see the following article: Update Office 2013 or Office 365


MSI-based Installations:
To fix this issue, install the June 7, 2016, update for Outlook 2013. For information about this update, click the following article number to view the article in the Microsoft Knowledge Base:

3115158 June 7, 2016, update for Outlook 2013 (KB3115158)


Workaround
If you can't install the update that's mentioned in the "Resolution" section to fix this issue, you can work around the issue by using one of the following options:

Option 1 - Enable Cached Exchange Mode
Use the steps in the following articles to enable Cached Exchange Mode in Outlook:

Turn on or off Cached Exchange Mode 


Option 2 - Enable Server-Side Synchronization
Switch the Mailbox record in Microsoft Dynamics CRM for your user to "Server-Side Synchronization or Email Router" instead of "Microsoft Dynamics CRM for Outlook". You can refer to the following article for additional details about how to configure Server-Side Synchronization.

Set up server-side synchronization of email, appointments, contacts, and tasks



More information
To determine whether your Office installation is Click-to-Run or MSI-based, follow these steps:
  1. Open an Office application, such as Outlook or Word.
  2. On the File menu, select Account or Office Account.
  3. For Office Click-to-Run installations, an Update Options item is displayed. For MSI-based installations, the Update Options item isn't displayed.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
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Article ID: 3142993 - Last Review: 07/07/2016 07:20:00 - Revision: 2.0

Microsoft Dynamics CRM 2016, Microsoft Dynamics CRM 2015, Microsoft Dynamics CRM 2013, Outlook 2016, Microsoft Outlook 2013, Microsoft Outlook 2010

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