Office 365 subscription automatic license renewal fails when heartbeatcache is in wrong location

Symptoms
When O365 paid subscription tries to renew, the license fails and eventually displays a red bar stating that the subscription is unlicensed.

Message 1: Couldn't Verify Subscription

We couldn't verify your Office 365 subscription, so most features of <application> have been disabled. Please make sure you're connected to the internet and restart your application.




Message 2: Application (Unlicensed Product)




Cause
The HeartbeatCache.xml file is located in the wrong folder.


Resolution
To resolve this issue, delete the heartbeatcache.xml file using the following steps.

1. Exit all Office applications. 

2. Browse to "C:\Program Files\Microsoft Office 15\root\vfs\Common AppData\microsoft\office\Heartbeat\"

3. Delete the HeartbeatCache.xml file

4. Launch one of the Office Applications and the file will be automatically placed the expected native folder location.


renewal fails subscription red bar heartbeatcache.xml
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
Properties

Article ID: 3147027 - Last Review: 03/09/2016 09:31:00 - Revision: 1.0

Microsoft Office Professional Plus 2013

  • KB3147027
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