No result when you use a number to search for an Excel attachment in Outlook or Outlook on the web

PROBLEM
When you use a number as a keyword to search for a Microsoft Excel attachment in an Exchange Online or Exchange Server 2016 account, no result is displayed in Outlook or Outlook on the web.
CAUSE
In Exchange Online and Exchange Server 2016, to optimize performance and improve the occurrences of a search instance, numbers in Excel attachments aren't indexed and parsed. This is expected behavior.
WORKAROUND

Outlook 2016

If you have Outlook 2016 and you're connected to an Exchange Server 2016 or Exchange Online mailbox by using Cached Exchange Mode, Outlook is likely using Exchange FAST search to query the mailbox. To optimize performance, Exchange FAST search shows the same behavior that's described in the Cause section. 

To work around this behavior, force Outlook 2016 to use the locally cached Windows Desktop Search (WDS) index. To force Outlook to fall back to WDS search, change the search scope to Subfolders, All Mailboxes, or All Outlook Items as shown in the following screen shot:

Screen shot of the search box in Outlook 2016, showing the Subfolders, All Mailboxes, and All Outlook Items options

Outlook 2013 and earlier versions

If you have Outlook 2013 or an earlier version, you might have Outlook configured to connect to the Exchange email account by using online mode. To work around this behavior, you can use Outlook in Cached Exchange Mode. For more information, see Turn on or off Cached Exchange Mode.

Properties

Article ID: 3166063 - Last Review: 06/01/2016 18:07:00 - Revision: 3.0

Microsoft Exchange Online, Exchange Server 2016 Enterprise Edition, Exchange Server 2016 Standard Edition

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