Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When you're using a Surface Pro 3 or Surface 3 device that's running Windows 8.1 to connect to a wireless display, you may experience one or more of the following symptoms:

  • When you try to connect to the wireless display, the connection fails, and you have to reboot the device to successfully connect to the wireless display.

  • When you connect to the wireless display, the connection to your wireless network stops working.

  • When you disconnect from the wireless display, the connection to your wireless network stops working.


These symptoms occur only when you connect to a wireless display that's configured in AGO mode. If you don't know whether your wireless display (or your wireless display adapter) supports or is configured in AGO mode, check the manufacturer's specifications. 

Cause

This problem occurs because of a timing issue in the Surface wireless network driver when it's used in a multi-channel wireless display configuration. 

Resolution

To resolve this issue, install an updated Windows 8.1 Marvell Wireless driver, version 15.68.3095.201 (MP201), for Surface Pro 3 and Surface 3.

To do this, follow these steps:

  1. Download the hotfix (KB3166547) from this article.

  2. Run the hotfix, and choose a folder where you want to unzip the files.

  3. In the folder that you saved the files to, right-click the mbtr8897w81x64.inf file, and then click Install.

  4. Right-click the mrvlpcie8897.inf file, and then click Install.

  5. Restart Windows.

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×