Users in an Exchange hybrid deployment can't access Office 365 groups in Outlook 2016

PROBLEM
You have a hybrid deployment of Exchange Online in Office 365 and on-premises Exchange Server. In this situation, your Autodiscover record resolves to an on-premises Exchange server, and users' mailboxes are in Exchange Online. When you create an Office 365 group in this scenario, users can't access the group through Microsoft Outlook 2016. However, users can access the group through Outlook on the web.
CAUSE
This issue occurs if the primary SMTP address of the Office 365 Group uses an incorrect format. For example: <Office365GroupName>@contoso.com. 

Modern groups use an Autodiscover XML file that's located in the %LocalAppData%\Microsoft\Outlook\16 folder. The primary SMTP address of the group should use the following format:
AutoD.<Office365GroupName>@contoso.mail.onmicrosoft.com
 
If the primary SMTP address of the group is <Office365GroupName>@contoso.com, the Autodiscover request fails because no object exists in the on-premises environment that represents the group.
SOLUTION
Change the primary SMTP address of the Office 365 group. To do this, run the following Windows PowerShell command:
Set-UnifiedGroup Alias -PrimarySmtpAddress <Office365GroupName>@contoso.mail.onmicrosoft.com
MORE INFORMATION
For more information, see Use PowerShell to manage Office 365 Groups.

Still need help? Go to Microsoft Community.
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Article ID: 3168347 - Last Review: 11/29/2016 18:29:00 - Revision: 3.0

Microsoft Exchange Online, Outlook 2016

  • o365e o365m o365022013 o365 o365a kbgraphxlink kbgraphic hybrid KB3168347
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