You are currently offline, waiting for your internet to reconnect

MS02-008: XMLHTTP control in MSXML 4.0 can allow access to local files

For additional information about this vulnerability, click the following article numbers to view the articles in the Microsoft Knowledge Base:
318203 MS02-008: XMLHTTP control in MSXML 3.0 can allow access to local files
318202 MS02-008: XMLHTTP control in MSXML 2.0 can allow access to local files
An information-disclosure vulnerability exists that could allow an attacker to read files on the local file system of a user who visits a specially malformed web site.

The attacker would not be able to add, change, or delete files. In addition, the attacker would not be able to use e-mail to carry out this attack; the vulnerability can only be exploited by way of a Web site. Customers who exercise caution when browsing and avoid visiting unknown or untrustworthy sites are at less risk from this vulnerability.
The vulnerability exists because the XMLHTTP control in the Microsoft XML Core Services does not respect the Internet Explorer Security Zone restrictions. This enables a Web page to specify a file on a user's local system as an XML data source as a means of reading the file.
To resolve this problem, obtain the latest service pack for Microsoft SQL Server 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
290211 How to obtain the latest SQL Server 2000 service pack
The following file is available for download from the Microsoft Download Center:
DownloadDownload the Msxml4qfe.exe package now.Release Date: February 21, 2002

For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Version       Size        File name     Platform   -------------------------------------------------------------   07-Feb-2002  4.00.9406.0   1,229,312   Msxml4.dll    x86   07-Feb-2002  4.00.9406.0      44,544   Msxml4a.dll   x86   07-Feb-2002  4.00.9406.0      82,432   Msxml4r.dll   x86				

Windows Installer 2.0 or later is required to install this fix. You may have to restart your computer after you install Windows Installer 2.0 or a later version of Windows Installer.

To download Windows Installer, visit one of the following Microsoft Web sites:

Note Windows XP users can skip this step.
Microsoft has confirmed that this problem may cause a degree of security vulnerability in Microsoft XML 4.0. This problem was first corrected in Microsoft SQL Server 2000 Service Pack 3.This problem was corrected in Microsoft XML 4.0 Service Pack 1.
To download the latest version of MSXML, visit the following Microsoft Web site:
More information
Affected versions of MSXML ship as part of several products. You should apply the patch to systems with any of the following Microsoft products:
  • Microsoft Windows XP
  • Microsoft Internet Explorer 6.0
  • Microsoft SQL Server 2000
MSXML can also be installed separately. MSXML is installed as a DLL in the System32 subfolder of the Windows operating system folder. On most systems, this will likely be C:\Windows or C:\winnt. If you have any or all of the following files in the System32 folder, you need the patch:
  • Msxml2.dll
  • Msxml3.dll
  • Msxml4.dll
If you have only Msxml.dll, you do not need the patch because this is an earlier, unaffected version.

Important The hotfix installer for this patch does not have an un-install feature.
For more information about this vulnerability, see the following Microsoft Web site:
security_patch kbMSXML400preSP1fix Security Update, February 13, 2002

Article ID: 317244 - Last Review: 06/22/2014 11:23:00 - Revision: 13.0

  • kbqfe kbhotfixserver kbbug kbfix kbie600presp1fix kbie600sp1fix kbsecbulletin kbsechack kbsecurity kbsecvulnerability kbsqlserv2000presp3fix kbsqlserv2000sp3fix kbwin2000presp3fix KB317244