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Email is not received when you use SendEmail macro action in Access

Symptoms
When you send email messages in Microsoft Access by using the SendEmail macro action, the messages are sent without any errors but aren't received by the intended recipient.
Cause
This problem occurs because the SendEmail macro action cannot verify the email addresses that are included in the To, Cc, and Bcc lines. The macro action checks these addresses against the SharePoint User Information List. However, the intended recipients are missing from the SharePoint list.
Resolution
To resolve this problem, make sure that the intended email recipients are listed in the User Information List. Users who were given explicit SharePoint site permissions are already listed. For users who were granted site permissions through a security group, make sure that those users have directly interacted with the SharePoint site or Access in order to be listed.
More information
You can check for the users who are listed in the User Information List by appending "_catalogs/users/detail.aspx" to the URL for the SharePoint site collection on which your Access application is located. For example, use the following URL: 

https://<tenant>.sharepoint.com/_catalogs/users/detail.aspx
References
For more information about the SendEmail macro, go to the following Office article:

web app Access Services Send EMail no data match info list error in resolving user
Properties

Article ID: 3177024 - Last Review: 08/04/2016 17:57:00 - Revision: 1.0

Microsoft Access 2013, Access 2016, Microsoft Access for Office 365

  • KB3177024
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