Error "You do not have permission to access these records" occurs when attempting to configure Microsoft Dynamics CRM for Microsoft Office Outlook

Symptoms
When you attempt to connect Microsoft Dynamics CRM for Microsoft Office Outlook, you encounter the following error message:

"You do not have permission to access these records. Contact your Microsoft Dynamics CRM administrator."

If you click Details, you see the following additional details:

Principal user (Id=<GUID>, type=8) is missing prvWriteUserSettings privilege (Id=588725dd-c878-41c5-a4c3-5efc93cd3ffd)    at Microsoft.Crm.Application.Commands.ApplicationCommand.UpdateUserSettingsLanguage(String propertyName, Int32 oldLcid, Int32 lcid, IOrganizationContextEx context, Boolean allowThrowingCrmException)
   at Microsoft.Crm.Application.Commands.ApplicationCommand.UpdateUserSettingsUICulture(Int32 lcid, IOrganizationContextEx context, Boolean allowThrowingCrmException)
   at Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.InitializeMapiStoreForFirstTime()
   at Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
   at Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure(Object stateInfo)
Cause
The language setting could not be set at the user level in CRM due to insufficient user privileges. The user's security role may be missing the Write privilege for the User Settings entity. 
Resolution
1. Sign into the Microsoft Dynamics CRM web application as a user with the System Administrator role.

2. Navigate to Settings > Security > Security Roles.

NOTE: If you are not using Microsoft Dynamics CRM 2015 or later, Security Roles is located under Administration instead of Security. 

3. Open the role that is assigned to this user.

4. Click on the Business Management tab and grant the “Write” privilege for the User Settings entity. User level access is the minimum requirement.

5. Click Save.

6. Attempt to connect Microsoft Dynamics CRM for Microsoft Office Outlook again.

If you are still encountering issues connecting CRM for Outlook to your CRM Online organization, run the Microsoft Support and Recovery Assistant to diagnose and fix the problem.
More information
If you are not sure which security role is assigned to the user, use the following steps:

1. Navigate to Settings > Security > Users.

NOTE: If you are not using Microsoft Dynamics CRM 2015 or later, Users is located under Administration instead of Security. 

2. Open the User record who is facing this issue.

3. On the command bar within the user record, click Manage Roles.

4. Locate the security role that has a checkmark next to it. Use the steps provided in the Resolution section to grant the Write privilege for the User Settings entity.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
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Article ID: 3187736 - Last Review: 08/19/2016 17:38:00 - Revision: 1.0

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