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"An impersonation error occurred" when connecting CRM Online to Exchange on-premises

Symptoms
When Server-Side Synchronization is configured between Microsoft Dynamics CRM Online and Exchange Server (on-premises), you receive one of the following errors after attempting to enable a mailbox:  

  • An impersonation error occurred in accessing the mailbox while sending the email message "Test Message". Mailbox <Mailbox name> didn't synchronize. The owner of the associated email server profile <Email Server Profile name> has been notified.
  • An impersonation error occurred in accessing the mailbox while receiving email. <Mailbox name> didn't synchronize. The owner of the associated email server profile <Email Server Profile name> has been notified.

Cause
This error can appear if the user account specified to access the mailbox does not have impersonation permissions for the mailbox.
Resolution
If you are providing credentials within an email server profile, make sure the user has impersonation permissions to each associated mailbox. For more information on configuring Exchange impersonation, see:

How to: Configure impersonation

Configuring Exchange Impersonation in Exchange 2010

Impersonation and EWS in Exchange
More information
When you click Details for one of the errors mentioned above, you may see details such as the following:

  • ActivityId: <GUID>
    >Error : System.Web.Services.Protocols.SoapException: The account does not have permission to impersonate the requested user.
       at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndFindItem(IAsyncResult asyncResult)
       at Microsoft.Crm.Asynchronous.EmailConnector.FindItemsStep.EndCall()
    at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeIncomingEmailProviderStep.EndOperation()
  • ActivityId: <GUID>
    >Error : System.Web.Services.Protocols.SoapException: The account does not have permission to impersonate the requested user.
       at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
       at System.Web.Services.Protocols.SoapHttpClientProtocol.EndInvoke(IAsyncResult asyncResult)
       at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeServiceBinding.EndCreateItem(IAsyncResult asyncResult)
       at Microsoft.Crm.Asynchronous.EmailConnector.ExchangeOutgoingEmailProvider.EndCreateItem()

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.
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Article ID: 3189639 - Last Review: 08/30/2016 14:52:00 - Revision: 2.0

Dynamics CRM Online

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