"A program is trying to send an e-mail message on your behalf" warning in Outlook

Symptoms
In Microsoft Outlook 2016 and Microsoft Outlook 2013, when you send an email message from another program such as Microsoft Excel, you receive the following warning message:

A program is trying to send an e-mail message on your behalf. If this is unexpected, click Deny and verify your antivirus software is up-to-date.
Cause
This warning message is displayed when a program tries to access your Outlook client to send an email message on your behalf, and your antivirus software is detected to be inactive or out-of-date.
Resolution
To fix this issue, use one of the following methods.

Method 1: Enable or update your antivirus application

To learn how Outlook detects your antivirus status, follow these steps:

  1. In Outlook, click File, and then click Options.
  2. Click Trust Center, and then click Trust Center Settings.
  3. Click Programmatic Access.
  4. View the Antivirus status that's listed in this window. If the status is anything other than Valid, follow the appropriate steps to enable your antivirus program, or update your antivirus program as necessary.

Method 2: Change the Programmatic Access Security setting in Outlook

  1. In Outlook, click File, and then click Options.
  2. Click Trust Center, and then click Trust Center Settings.
  3. Click Programmatic Access.
  4. Select the option that you prefer. If you want to stop these warning messages permanently, select the Never warn me about suspicious activity (not recommended) option.



    Note If these options are not available, exit Outlook, and then start Outlook again in elevated mode. To do this, type Outlook on the desktop or in the Start Search box, right-click the Microsoft Outlook search result, click Properties, click the Compatibility tab, and then click Run this program as an administrator.
  5. Click OK two times.
The registry data that is associated with the Programmatic Access Security options is as follows.

Office Click-to-Run Installations:

Same Bitness (32-bit Office running on 32-bit Windows or 64-bit Office running on 64-bit Windows):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\Software\Microsoft\Office\x.0\Outlook\Security

Different Bitness (32-bit Office running on 64-bit Windows):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\Software\Wow6432Node\Microsoft\Office\x.0\Outlook\Security

Office MSI-Based installations:

Different Bitness (32-bit Office running on 64-bit Windows):
HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\x.0\Outlook\Security

Same bitness (32-bit Office running on 32-bit Windows or 64-bit Office running on 64-bit Windows):
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\x.0\Outlook\Security

NoteThe x.0 placeholder represents your version of Office (16.0 = Office 2016, 15.0 = Office 2013)

DWORD: ObjectModelGuard

Values:
0 = Warn me about suspicious activity when my antivirus software is inactive or out-of-date (recommended)
1 = Always warn me about suspicious activity
2 = Never warn me about suspicious activity (not recommended)
More information
To determine whether your Office installation is Click-to-Run or MSI-based, follow these steps:

  1. Start Outlook.
  2. On the File menu, click Office Account.
  3. For Office Click-to-Run installations, an Update Options item is displayed. For MSI-based installations, the Update Options item isn't displayed.

    Click-to-Run Office installationMSI-based Office installation
    Click-to-Run screen shotMSI screen shot
Properties

Article ID: 3189806 - Last Review: 09/08/2016 00:36:00 - Revision: 1.0

Outlook 2016, Microsoft Outlook 2013

  • KB3189806
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