Can't preview .msg files in Windows File Explorer with 64-bit Outlook

Original KB number:   3189902

Symptoms

You have an .msg file saved in a folder on your computer. In Windows File Explorer, you select the .msg file to view it in the Preview Pane. In this situation, you receive the following error message:

Either there is no default mail client or the current mail client cannot fulfill the messaging request. Please run Microsoft Outlook and set it as the default mail client.

Screenshot of the mail client error details.

After you select OK, the following error message is displayed in the Preview Pane:

This file can't be previewed because of an error in the Windows e-mail previewer.

Screenshot of file preview error details.

Cause

This issue occurs when you have the 64-bit version of Microsoft Outlook installed. The Windows preview host requires a 32-bit application previewer. When 32-bit Outlook is installed, it acts as the previewer. Without 32-bit Outlook installed, there is no previewer available for .msg files.

Workaround Method 1 - Disable the Windows Explorer Preview Pane, and open the .msg file to view it in Outlook

  1. Open Windows File Explorer.
  2. On the View tab, select the Preview pane to disable it.
  3. To view the .msg file, double-click it to open it in Outlook.

Workaround Method 2 - Use 32-bit Outlook

If you prefer to preview .msg files in Windows File Explorer, install the 32-bit version of Outlook instead of the 64-bit version.