Retention policy no longer works after a mailbox is moved from the on-premises environment to Exchange Online

PROBLEM
When you move a mailbox from the on-premises Exchange environment to Exchange Online in a hybrid deployment, the retention policy that's applied to the mailbox no longer works.

You experience this issue even though you took one or both of the following actions:

  • You re-created the retention policy and assigned it to the mailbox.
  • You re-created the retention tag and added it to the retention policy.
CAUSE
Retention hold is enabled on the mailbox. By default, retention hold is enabled when a mailbox is moved from the on-premises organization to Exchange Online. When a mailbox is placed on retention hold, the processing of the retention policy for that mailbox is suspended.

To verify that retention hold is enabled on a mailbox, follow these steps:

  1. Connect to Exchange Online by using remote PowerShell. For more information, see Connect to Exchange Online PowerShell.
  2. Run the following command:
    Get-mailbox user@contoso.com |fl
  3. Examine the output. If the RetentionHoldEnabled parameter is set to True, retention hold is enabled.
SOLUTION
Disable retention hold on the mailbox. To do this, follow these steps:

  1. Connect to Exchange Online by using remote PowerShell. For more information, see Connect to Exchange Online PowerShell.
  2. Run the following command:
    Set-Mailbox user@contoso.com -RetentionHoldEnabled $false
MORE INFORMATION
Still need help? Go to Microsoft Community or the Exchange TechNet Forums.
Properties

Article ID: 3194755 - Last Review: 10/13/2016 23:02:00 - Revision: 2.0

Microsoft Exchange Online, Exchange Server 2016 Enterprise Edition, Exchange Server 2016 Standard Edition, Microsoft Exchange Server 2013 Enterprise, Microsoft Exchange Server 2013 Standard

  • o365 hybrid KB3194755
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