"Cannot localize the default folders" error when a user tries to change the default folder names in Outlook on the web to another language

PROBLEM
A user is unable to change the default folder names (such as Inbox and Sent Items) in Outlook on the web to another language. When the user specifies a language in the Language box and then selects the Rename default folders so their names match the specified language check box on the "Region and time settings" page in Outlook on the web, they receive the following error message:
The localization operation of the default folders of mailbox "User@Contoso.com" failed:Cannot localize the default folders.
Additionally, you may have taken the following actions to try to reset default folder names to the new language but they didn't resolve the issue:
  • Run the Outlook.exe /ResetFolderNames command.
  • Run the following command: 
    Set-MailboxRegionalConfiguration -id <alias> -LocalizeDefaultFolderName:$true -Language <Language_code_to_switch_to> -DateFormat <your_preferred_DateFormat>
CAUSE
The mailbox contains one or more folders whose name is the same as one or more default folder names in the new language. The default folders are  Inbox, Sent Items, Drafts, Junk Email, RSS Subscriptions and Deleted Items.

For example, the mailbox contains a folder named "Postvak In", which is the Dutch name for "Inbox". A user will experience this issue if they try to change the language of default folder names to Dutch because a folder named "Postvak In" already exists. 
SOLUTION
Rename the existing folders in the mailbox so that they have unique names. Then, specify a language and select the check box to rename default folders to match the specified language. ​
MORE INFORMATION
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Article ID: 3196480 - Last Review: 10/01/2016 00:41:00 - Revision: 1.0

Microsoft Exchange Online

  • o365 KB3196480
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