Slow Browsing to Windows 98 or Windows Me Clients from Windows XP

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

This article has been archived. It is offered "as is" and will no longer be updated.
Symptoms
If the following conditions exist, you may experience slow browsing for file shares and printers that are on Microsoft Windows 98-based or Microsoft Windows Millennium Edition-based computers:
  • You are browsing from a Windows XP-based client computer.
  • Both computers are part of a workgroup.
  • The Windows 98 or Windows Millennium Edition (Me) client has a password-protected file share.
  • You are using the "Save this password" feature on your Windows XP client computer.
Cause
Windows XP saves the password in the Credential Manager. When you browse the same Windows 98 or Windows Me client, Credential Manager tries to contact a domain controller to validate the password. Because the computers are in a workgroup environment, there is no domain controller, and you must wait until the requests timeout.
Resolution
To resolve this problem, obtain the latest service pack for Windows XP. For additional information, click the following article number to view the article in theMicrosoft Knowledge Base:
322389 How to Obtain the Latest Windows XP Service Pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this fix should have the following file attributes or later:
   Date         Time   Version      Size     File name   ------------------------------------------------------   04-Jun-2002  17:29  5.1.2600.46  257,536  Kerberos.dll				

Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows XP Service Pack 1.
Properties

Article ID: 322097 - Last Review: 01/11/2015 21:48:50 - Revision: 2.0

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbenv kbfix kbnetwork kbsecurity kbui kbwinxpsp1fix KB322097
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