Explorer.exe Repeatedly Generates Access Violation Error Messages After You Log On

This article was previously published under Q326572
This article has been archived. It is offered "as is" and will no longer be updated.
Symptoms
After you log on, Explorer.exe may repeatedly generate access violation error messages. The access violation occurs in the Browseui.dll module. However, this symptom does not occur when you log on with administrator rights.
Cause
This problem may occur if one or more registry keys are inaccessible. The inability to obtain access to registry keys would run an errant code path that would always cause a fault. The fault occurs because the incorrect release method was being called on the object.
Resolution

Service Pack Information

To resolve this problem, obtain the latest service pack for Microsoft Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to Obtain the Latest Windows 2000 Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.For Internet Explorer 5.01, the English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name   --------------------------------------------------------   29-Jul-2002  17:21  5.0.3502.5983  792,848  Browseui.dll				
For Internet Explorer 5.5 Service Pack 2, the English version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version        Size     File name   --------------------------------------------------------   02-Dec-2002  16:48  5.50.4924.200  814,864  Browseui.dll				

Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Microsoft Windows 2000 Service Pack 4.
More information
If the correct symbols are installed, the Drwtsn32.log file contains the following registry state and stack:
eax=00000006 ebx=7118c688 ecx=00000007 edx=00000001 esi=7113ead0 edi=80004005eip=71187da9 esp=00f8e088 ebp=00f8e10c iopl=0     nv up ei pl zr na po nccs=001b  ss=0023  ds=0023  es=0023  fs=0038  gs=0000      efl=00000246browseui!CEMDBLog::SetRoot+11:71187da9 83662000 and dword ptr [esi+0x20] (7113eb4c)},0x00:007> kChildEBP RetAddr  00f8e088 7113e5a9 browseui!CEMDBLog::SetRoot+0x1100f8e094 70bd1966 browseui!CEMDBLog::Initialize+0xd00f8e10c 7113e341 SHLWAPI!IUnknown_AtomicRelease+0x1700f8e10c 7113e341 browseui!CUserAssist::Initialize+0x2900f8e124 7113e2ec browseui!CUserAssist::Initialize+0x2900f8e12c 7113e262 browseui!CUserAssist_CI2+0x2500f8e148 711287bb browseui!CUserAssist_CreateInstance+0x2200f8e168 77a58661 browseui!CClassFactory::CreateInstance+0x4300f8e1d8 77a582ca OLE32!CServerContextActivator::CreateInstance+0x1bb00f8e1f4 77a584d3 OLE32!ActivationPropertiesIn::DelegateCreateInstance+0x4a00f8e218 77a58447 OLE32!CApartmentActivator::CreateInstance+0x3a00f8e234 77a57d88 OLE32!CProcessActivator::CCICallback+0x5900f8e254 77a57c9f OLE32!CProcessActivator::AttemptActivation+0x2a00f8e298 77a58403 OLE32!CProcessActivator::ActivateByContext+0x4a00f8e2c0 77a582ca OLE32!CProcessActivator::CreateInstance+0x3200f8e2dc 77a58376 OLE32!ActivationPropertiesIn::DelegateCreateInstance+0x4a00f8e528 77a582ca OLE32!CClientContextActivator::CreateInstance+0x8000f8e544 77a54518 OLE32!ActivationPropertiesIn::DelegateCreateInstance+0x4a00f8ecb0 77a5431d OLE32!ICoCreateInstanceEx+0x26d00f8ecd8 77a546ea OLE32!CoCreateInstanceEx+0x2b				
NOTE: Note that the general registers may differ, but the crash occurs on the "and dword ptr [esi+0x20]" instruction.

For additional information about how to obtain a hotfix for Windows 2000 Datacenter Server, click the article number below to view the article in the Microsoft Knowledge Base:
265173 The Datacenter Program and Windows 2000 Datacenter Server Product
For additional information about how to install multiple hotfixes with only one reboot, click the article number below to view the article in the Microsoft Knowledge Base:
296861 Use QChain.exe to Install Multiple Hotfixes with One Reboot
Properties

Article ID: 326572 - Last Review: 10/26/2013 08:50:00 - Revision: 4.0

Microsoft Windows 2000 Server, Microsoft Windows 2000 Advanced Server, Microsoft Windows 2000 Professional Edition

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