Error Message: DVD Playback Failed Due to a Problem in the Video Subsystem

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

This article has been archived. It is offered "as is" and will no longer be updated.
Symptoms
When you try to play video from a DVD, you may receive the following error message:
Playback failed due to a problem in the video subsystem.
Cause
This issue may occur if your DVD decoder is not compatible with Windows XP.
Resolution
To resolve this issue, obtain and install a DVD decoder that is compatible with Windows XP. To obtain a list of compatible DVD decoders for Windows XP:
  1. Click Start, then click Help and Support.
  2. In the Search box, type DVD decoder, and then press ENTER.
  3. Click If you do not have a DVD decoder to read the "If you do not have a DVD decoder" topic.
More information
To determine what DVD decoder is installed on your computer, click Start, click Run, type dvdupgrd /detect, and then click OK.

For additional information about DVD playback issues, click the following article number to view the article in the Microsoft Knowledge Base:
306318 Troubleshooting DVD Playback in Windows Media Player for XP

For additional information about DVD decoders, click the following article number to view the article in the Microsoft Knowledge Base:
306331 Supported Software MPEG-2 DVD Decoders in Windows Media Player
Properties

Article ID: 326685 - Last Review: 01/12/2015 20:44:05 - Revision: 2.0

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • kbnosurvey kbarchive kberrmsg kbprb KB326685
Feedback