Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Summary

When you start one of the games that are listed in the "Applies To" section, your game crashes or stops responding. Additionally, you receive an error message that resembles the following:

Microsoft XML x.x is required. Msxml file is not correctly installed and a file is missing Msxml 4.0 is not installed correctly and is required to run the game.

The game may start, but the text in the game does not appear correctly.

This problem occurs if the application cannot find Microsoft XML (MSXML) 4.0 or a later version installed on your computer. The MSXML service is necessary to run your game.

Cause

This problem occurs because you must have Microsoft XML (MSXML) 4.0 installed to run these games.

Resolution

To resolve this problem, use the following methods in the order that they are presented.

Method 1: Restart the computer by using a clean startup procedure

When you start Microsoft Windows, other software may start “automatically” with the operating system. These programs and services can include antivirus and system utilities that may interfere with the game. When you perform a Clean Boot, you prevent these programs from starting automatically.

You must be logged on as an administrator or as a member of the Administrators group to complete this procedure. If the computer is connected to a network, network policy settings may also prevent you from completing this procedure.


To view detailed steps on starting your computer in a Clean Boot state, please refer to the following Microsoft Knowledge Base article:

331796 Perform a clean startup to determine whether background programs are interfering with your game or program

Method 2: Download and install the latest Microsoft XML Core Services

Some games will include MSXML 4.0 on the installation CD or DVD discs. However, downloading the latest version of Microsoft XML Core Services is the best solution. To obtain the latest version, please follow these steps:

  1. Visit the following Microsoft Web site:

    http://www.microsoft.com/download/details.aspx?familyid=3144B72B-B4F2-46DA-B4B6-C5D7485F2B42&displaylang=en

  2. Scroll to the bottom of the page.

  3. Locate and download the following files:

    • Msxml.msi

    • Msxmlcab.exe

    Note Save the downloaded files to the desktop.

  4. When the download is complete, double-click Msxml.msi, and then follow directions on your screen.

  5. Restart the computer when you are prompted.

  6. After the computer restarts, start the game.

If the problem continues to occur, go to method 3.

Method 3: Extract and register the XML files

Step 1: Extract the files

To extract the files, follow these steps:

  1. Double-click the Mxmlcab.exe file that you download in method 2.

  2. When you are prompted, select the desktop as the location for the extracted file. Then, click OK.

  3. On the desktop, right-click the Msxml4 file, and then extract the new files to the desktop.

  4. Copy the four files that are extracted in step 3 to the following folder:

    <drive>:\Windows\System 32Note In this path, <drive> represents the drive on which the operating system is installed.

Step 2: Register the files

To register the files, follow these steps:

  1. Click Start Start button , and then click Run.

  2. In the Run box, type regsvr32 MSXML4.dll, and then click OK.

    Note You should receive the following message:

    DllRegisterServer in msxml4.dll succeeded.

  3. Click OK.

More Information

For more information about how to reinstall the XML 4.0 Parser, click the following article number to view the article in the Microsoft Knowledge Base:

324460 How to install Microsoft XML Parser and Microsoft XML Core Services (MSXML)

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×