You are currently offline, waiting for your internet to reconnect

"No Valid System Partitions Were Found" Error Message When You Use WinPE to Install Windows

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

SYMPTOMS
When you try to use the Microsoft Windows Preinstallation Environment (WinPE) feature and the Diskpart tool to deploy a Windows Server 2003 image, you receive the following error message when you run the Winnt32.exe command to start Setup:
No valid system partitions were found. Setup is unable to continue.
CAUSE
This issue may occur if you used Diskpart before you run Winnt32.exe to create partitions.
RESOLUTION
To resolve this issue, edit your installation scripts or batch files to prepare the installation hard disk. To do this, add the following entry to the Winnt32.exe command in your script
/syspart:X:
where X: is the drive letter of the hard disk that you want to install Windows on. Note that a colon must appear after the drive letter.
Properties

Article ID: 817577 - Last Review: 12/03/2007 03:28:28 - Revision: 4.5

  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
  • kberrmsg kbprb KB817577
Feedback