OL2002: The Wrong Name Becomes the Focus in the List of E-mail Messages When You Type a DBCS for the First Character of the Sender's Display Name

This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
If all the following conditions are true for an e-mail message in Outlook 2002
  • You have your e-mail messages sorted by the From column.

    -and-
  • The message list is the focus of Microsoft Outlook.

    -and-
  • You use the Input Method Editor (IME) to type the first character of the sender’s display name.

    -and-
  • The first character of the sender’s display name is in a Double Byte Character Set (DBCS) font.
the wrong name becomes the focus in the list of e-mail messages when you type the first character of the sender's display name in the IME.
CAUSE
This problem occurs because Outlook 2002 does not convert the DBCS character to a Unicode character causing Outlook 2002 to match the wrong display name.
RESOLUTION

Service Pack Information

This problem is corrected in Office XP Service Pack 3.To resolve this problem, obtain the latest service pack for Microsoft Office XP. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
307841 How to obtain the latest Office XP Service Pack

Hotfix Information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The global version of this fix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date        Time      Size      File name        ---------------------------------------------   01-May-2003 20:08:20  3,242,416 Outlookop.msp   01-May-2003 22:28:39  7,021,704 Outlookff.msp				
After the hotfix is installed, the global version of this fix will have the file attributes (or later) that are listed in the following table:
   Date        Time     Version     Size      File name        -------------------------------------------------------   20-Dec-2002 00:41:09 10.0.4817.0   109,128 Envelope.dll   09-Jan-2003 22:31:38 10.0.4907.0   346,696 Exsec32.dll   09-Aug-2002 03:22:19 10.0.4406.0   137,800 Impmail.dll   28-Feb-2003 01:56:58 10.0.5025.0   543,304 Outlcm.dll   14-Mar-2003 07:55:17 10.0.5112.0   100,936 Outlctl.dll   01-May-2003 02:31:52 10.0.5229.0 6,318,664 Outllib.dll   11-Oct-2002 22:14:24 10.0.4608.0    92,744 Outlmime.dll   01-May-2003 02:31:55 10.0.5229.0    47,688 Outlook.exe   22-Mar-2003 03:06:34 10.0.5119.0   121,416 Outlph.dll   25-Nov-2002 18:50:20 10.0.4721.0    47,688 Recall.dll				
This fix is a post-Office XP Service Pack 2 (SP-2) fix. To install the fix, you must have Office XP SP-2 installed. For additional information about Office XP SP-2, click the following article number to see the article in the Microsoft Knowledge Base:
325671 OFFXP: Overview of the Office XP Service Pack 2
Additionally, you may have to install Windows Installer 2.0 to install this fix. For additional information about the Windows Installer requirement for post-Office XP SP-2 fixes, click the following article number to see the article in the Microsoft Knowledge Base:
330537 OFFXP: Office XP Updates and Patches Released After September 2002 May Require Windows Installer 2.0

STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Office XP Service Pack 3.
kb2HR1
Properties

Article ID: 819969 - Last Review: 01/07/2015 17:07:39 - Revision: 3.2

  • Microsoft Outlook 2002 Service Pack 2
  • kbnosurvey kbarchive kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbofficexppresp3fix KB819969
Feedback