COM Components That Are Configured Correctly in a COM+ Server Application Can Be Loaded in the Client Process

This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
Microsoft Component Object Model (COM) components that are configured correctly in a Microsoft COM+ Server Application can be activated in the client process application (in-process activation). This behavior must occur for COM components that are configured in a COM+ Library Application and are not configured in a COM+ Server Application (out-of-process activation).
CAUSE
This problem occurs if the COM+ runtime fails to get the information about a component from the COM+ catalog.
RESOLUTION

How to Obtain the Hotfix

This issue is fixed in the Microsoft Windows 2000 Post-Service Pack 4 (SP4) COM+ 1.0 Hotfix Package 27. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
822618 INFO: Availability of Windows 2000 Post-Service Pack 4 COM+ Hotfix Rollup Package 27
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.
kbWin2000preSP5COMRollup27Fix
Properties

Article ID: 822544 - Last Review: 02/27/2014 18:44:11 - Revision: 2.1

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft COM+ 1.0
  • kbnosurvey kbarchive kbbug kbfix kbqfe kbwin2000presp5fix KB822544
Feedback