Entries in Hinv32.log Report Contains Error Reports Even When Hardware Inventory Data is Reported to the Sites Server

This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
When you review the Hinv32.log on a Microsoft Systems Management Server (SMS) 2003 client, you may see the following entries in the log file:
CItemImpl::SetValue - Failed to set value Type to SMS_HARDWARE_INVENTORY_FILE, the error code is 0x80070002CItemImpl::SetValue - Failed to set value Source to C:\WINDOWS\MS\SMS\clicomp\hinv\outbox\ihpltckm.inv, the error code is 0x80070002CItemImpl::SetValue - Failed to set value Destination Pattern to ????????.NHM, the error code is 0x80070002
These log entries may occur even though the hardware inventory was correctly reported to the SMS site.
CAUSE
This problem occurs because log entries are added to the SMS 2003 client software. The log entries help track a status message that failures with the SMS Copy Queue component cause.

You can safely ignore the three log entries in the "Symptoms" section of this article. After these three log entries, an entry appears in the log that indicates if the inventory item was inserted successfully. If the inventory task is successful, the following entry appears in the log:
Copy Queue - New item 'Item 233886' fully inserted
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section of this article.
Properties

Article ID: 829860 - Last Review: 12/28/2014 22:01:50 - Revision: 1.2

Microsoft Systems Management Server 2003

  • kbnosurvey kbarchive kbclient kbinventory kbnofix kbbug KB829860
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