"You do not have permission to open this file" error when you try to start Microsoft Dynamics GP

This article provides resolutions for the "You do not have permission to open this file" error that you receive when you start Microsoft Dynamics GP.

Applies to:   Microsoft Dynamics GP
Original KB number:   843755

Symptoms

When you try to start Microsoft Dynamics GP, you receive the following error message:

You do not have permission to open this file.

Cause 1

The Dynamics.set file may be damaged.

Resolution

To resolve this problem, copy the Dynamics.set file from a computer that does not receive the error message.

Note

When you copy a Dynamics.set file from one computer to another, keep in mind the same products should be listed in each file.

Cause 2

The Dynamics.set file may contain an incorrect path of a dictionary file.

Resolution

To resolve this problem, follow these steps:

  1. Locate the Dynamics.set file. By default, this file is located in the installation folder.

    In Microsoft Dynamics GP, the path of the installation folder is C:\Program Files\Microsoft Dynamics\GP.

  2. Right-click the Dynamics.set file, select Open with > Select the program from a list > OK > Notepad, and then select OK.

  3. Verify that all paths that are listed for the dictionary files are correct. Then, make sure that you can open all the listed folders.

Cause 3

A dictionary that is referenced in the Dynamics.set file may be marked as read-only.

Resolution

To resolve this problem, follow these steps:

  1. Locate the Dynamics.set file. By default, this file is located in the installation folder.

    In Microsoft Dynamics GP, the path of the installation folder is C:\Program Files\Microsoft Dynamics\GP.

  2. Right-click the Dynamics.set file, select Open with > Select the program from a list > OK > Notepad, and then select OK.

  3. Note the locations for all the dictionary files.

  4. Verify the properties of each dictionary file. To do this, right-click the file, and then select Properties.

  5. If a dictionary file is marked as read-only, disable the read-only attribute, and then select OK.

Cause 4

A folder where a dictionary file is located may have incorrect permissions settings. The dictionary file is referenced in the Dynamics.set file.

Resolution

  1. Locate the Dynamics.set file. By default, this file is located in the installation folder.

    In Microsoft Dynamics GP, the path of the installation folder is C:\Program Files\Microsoft Dynamics\GP.

  2. Right-click the Dynamics.set file, select Open with > Select the program from a list > OK > Notepad, and then select OK.

  3. Note the locations for all the dictionary files.

  4. Verify the permissions to the folders where the dictionary files are located. To verify the permissions, right-click the folder, select Properties, and then select the Security tab. Make sure that the user or the user group that is receiving the error message has full control.

    Note

    If the dictionary file is located in a shared folder, verify the permissions to the share folder where the dictionary file is located. By default, users and groups are given only read permissions. To do this, follow the appropriate steps:

    • If you use Windows Server:
      1. Right-click the folder, select Properties, select the Sharing tab, and then select Advanced Sharing.
      2. Select Permissions, and then make sure that the user or the user group that is receiving the error message has full control.