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Error message when you select a batch in the Build Payroll Checks window in Microsoft Dynamics GP

Symptoms
When you select a batch in the Build Payroll Checks window in Microsoft Dynamics GP, you may receive one of the following error messages:
Error message 1
Error - "Open operation on UPR_Temp_Post2 has incorrect record length"
Error message 2
Error - "Remove Range Operation on Table ddDeposits has caused known error 2"
Error message 3
Error - "Batches with zero transactions cannot be marked"
Error message 4
Error - "Another user is performing a check run"
Error message 5
Error - "UPR_Work_Post failed accessing SQL data"
Error message 6
Error - "The employee record cannot be inactivated or deleted Pay run is in progress for this employee"
Error message 7
Error - "Checks cannot be calculated. Errors were found."
Error message 8
Error - "You cannot void a check. A computer check run is in process."
Error message 9
Error - "You cannot edit a batch marked for posting"
Error message 10
Error - "Batch is marked for posting and cannot be edited."
Additionally, an Open Operation error, a Get/Change error, or a Save Operation error may occur on one of the following files to indicate that the Payroll batch is stuck:
  • UPR_WORK_MSTR
  • UPR_WORK_MSTR_Detail
  • UPR_WORK_HDR
  • UPR_WORK_Pay_Type
  • UPR_WORK_Deduction
  • UPR_WORK_Benefit
  • UPR_WORK_State_Tax
  • UPR_WORK_Local Tax
  • UPR_WORK_Check
  • UPR_WORK_Post
  • UPR_Flat_Tax_Records
  • UPR_Account_Cache
Cause
This problem may occur if the payroll work tables have not been cleared. The payroll work tables must be cleared to release the batch.
Resolution
Note Before you follow the instructions in this article, make sure that you have a complete backup copy of the database that you can restore if a problem occurs

To resolve this problem, follow these steps:

Step 1: Delete records in Payroll work tables

Follow one of the options below to delete the activity from the payroll work tables. To have us delete records for you, go to the Option 1: "Fix it for me" section. To delete records yourself, go to the Option 2: "Let me fix it myself" section.
Option #1: Fix it for me
To clea the payroll work temp tables automatically, have all users exit Microsoft Dynamics GP, and then click the Fix this problem button or link. Click Run in the File Download dialog box, and then follow the steps in the Fix it wizard.

Note This wizard may be in English only; however, the automatic fix also works for other language versions of Windows.

Note If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.
Option #2: Let me fix it myself

To clear the payroll work tables yourself, follow these steps:
  1. Open Microsoft SQL Server using the appropriate method below:
    • If you use Microsoft SQL Server 2008, start SQL Server Management Studio. To do this, click Start, point to All Programs, point to Microsoft SQL Server 2008, and then click SQL Server Management Studio.
    • If you use Microsoft SQL Server 2005, start SQL Server Management Studio. To do this, click Start, point to All Programs, point to Microsoft SQL Server 2005, and then click SQL Server Management Studio.
    • If you use Microsoft SQL Server 2000, start SQL Query Analyzer. To do this, click Start, point to All Programs, point to Microsoft SQL Server, and then click Query Analyzer.
  2. Run delete statements against the company database.

    Note The first two lines in the script delete the contents of the activity files in the Dynamics database. The other lines delete the contents of the work files and the activity files in the Company database.
    Delete DYNAMICS..UPR10300Delete DYNAMICS..UPR10304Delete UPR10200Delete UPR10201Delete UPR10202Delete UPR10203Delete UPR10204Delete UPR10205Delete UPR10206Delete UPR10207Delete UPR10208Delete UPR10209Delete UPR10213Delete UPR10301Delete UPR19900Delete UPR19901
  3. If you use Direct Deposit, run delete statements for Direct Deposit:
    Delete DD10100 --(Direct Deposit Employee Deposit Work) Delete DD10200 --(Direct Deposit ACH Copy) Delete DD10300 --(Direct Deposit ACH Cross Reference) Delete DD10400 --(Direct Deposit ACH Header) - If this file is renamed or deleted, you will lose any builds in the generate ACH file window (Transactions | Payroll | Generate ACH file.) Delete DD10500 --(Direct Deposit ACH Items) - If this file is renamed or deleted, you will lose any builds in the generate ACH file window (Transactions | Payroll | Generate ACH file.) Delete DD10600 --(Direct Deposit Prenotes Completed) Delete DD10700 --(Direct Deposit Exceptions)






Step 2: Delete temporary files

To delete temporary files, open Windows Explorer, and then click the Temporary directory. The Temporary directory has the following path:

C:\Windows\Temporary

In the directory, delete the files that begin with TNT. Then, delete the files that have a .tmp file name extension.

Step 3: Perform Check Links

Check Links will check the linking of the data between the tables to ensure data integrity. To do this, follow these steps:
  1. Use the appropriate method to open the check Links window.
    • In Microsoft Dynamics GP 10.0 or Microsoft Dynamic GP 2010, click Microsoft Dynamics GP, click Maintenance, and then click Check Links.
    • In Microsoft Dynamics GP 9.0, click File, point to Maintenance, and then click Check Links.
  2. In the Series list, click Payroll.
  3. In the Logical Tables list, click Payroll Transactions, click Insert, and then click OK.
  4. In the Report Destination dialog box, click to select the appropriate check box, and then click OK.

    Note You can safely ignore the error messages that occur in the error log. The Check Links process is reattaching the batch ID to the existing transactions.

Step 4: Build the check file

Build the check file again. All the batches are still in the check file.

Note If you have recurring batches, and you delete the UPR10301 file in step 1, the frequency defaults back to single use when you run the Check Links process. Before you post the batch, click Transactions, click Payroll, and then click Batches. Select the recurring batch, and then change the frequency to a frequency other than Single.


851664
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Article ID: 851664 - Last Review: 04/04/2013 21:44:00 - Revision: 12.0

  • Microsoft Dynamics GP 2013
  • Microsoft Dynamics GP 2010
  • Microsoft Dynamics GP 10.0
  • Microsoft Dynamics GP 9.0
  • kberrmsg kbexpertisebeginner kbtshoot kbprb kbexpertiseinter kbmbsmigrate kbmsifixme kbfixme KB851664
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