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Error message when you try to print the Receivables Transaction History Removal report in Microsoft Dynamics GP: "Unable to remove this transaction: an open apply record exists or an apply record exists outside the selected range"

Symptoms
When you try to print the Receivables Transaction History Removal report in Microsoft Dynamics GP, you receive the following error message in the header and applies to the document if it has an asterisk next to it: 
Unable to Remove This Transaction: an open apply record exists or an apply record exists outside the selected range.
Cause
If an asterisk does not appear next to a specific document, the history was successfully removed. The message is listed in the header of the document and only applies it the document has an asterisk next to it. It is by design that the history will not be removed if you have the setup marked to retain history.
Resolution
To resolve this problem, follow these steps:
  1. Open the Receivables Management Setup dialog box. To do this, follow the appropriate step:
    • In Microsoft Dynamics GP 10.0 and higher versions, point to Tools on the Microsoft Dynamics GP menu, point to Setup, point to Sales, and then click Receivables.
    • In Microsoft Dynamics GP 9.0 or in earlier versions, point to Setup on the Tools menu, point to Sales, and then click Receivables.
  2. Click to clear the Print Historical Aged Trial Balance check box, and then click OK.
  3. Open the Remove Transaction History dialog box, and then remove the transaction in the Remove Receivables Transaction History dialog box. To open the Remove Transaction History dialog box, follow the appropriate step:
    • In Microsoft Dynamics GP 10.0 and higher versions, point to Tools on the Microsoft Dynamics GP menu, point to Utilities, point to Sales, and then click Remove Transaction History.
    • In Microsoft Dynamics GP 9.0 or in earlier versions, point to Utilities on the Tools menu, point to Sales, and then click Remove Transaction History.
    Note To maintain data integrity, remove both the debit document and the applied credit document.
  4. Open the Receivables Management Setup dialog box, click to select the Print Historical Aged Trial Balance check box, and then click OK.
TechKnowledge Document ID: 22467
Properties

Article ID: 871985 - Last Review: 03/29/2016 22:28:00 - Revision: 6.0

Microsoft Dynamics GP 2015, Microsoft Dynamics GP 2013, Microsoft Dynamics GP 2010, Microsoft Dynamics GP 10.0, Microsoft Dynamics GP 9.0, Microsoft Business Solutions–Great Plains 8.0, Microsoft Business Solutions–Great Plains 7.5, Microsoft Great Plains Dynamics 7.0, Microsoft Great Plains eEnterprise 7.0, Great Plains Dynamics 6.0, Great Plains eEnterprise 6.0

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