You are currently offline, waiting for your internet to reconnect

Device Manager displays a yellow exclamation point for the Parport driver in Windows XP and in Windows 2000

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Notice
This article applies to Windows 2000. Support for Windows 2000 ends on July 13, 2010. The Windows 2000 End-of-Support Solution Center is a starting point for planning your migration strategy from Windows 2000. For more information see the Microsoft Support Lifecycle Policy.
SYMPTOMS
You may experience the following symptoms in Device Manager on a Microsoft Windows XP-based or on a Microsoft Windows 2000-based computer:
  • When you click Show hidden devices on the View menu, you see an exclamation point in a yellow circle next to the Parport device that is listed under Non-Plug and Play Drivers.
  • When you double-click Parport, and then click the General tab, you receive the following message in the Device status box:
    This device is either not present, not working properly, or does not have all the drivers installed. (Code 24)
CAUSE
This problem may occur if either of the following conditions were true before you installed Windows XP or Windows 2000:
  • The computer was not equipped with parallel port hardware.
  • The computer was equipped with parallel port hardware, but the parallel port hardware had been disabled in the ROM BIOS.
The problem occurs because Windows XP and Windows 2000 automatically install the parallel port arbitrator (Parport) driver even if no parallel port hardware is present. When this behavior occurs, the Parport driver cannot load, and the device appears in Device Manager next to an exclamation point in a yellow circle.
RESOLUTION
While there is no resolution for this problem, no harm is done by it. The problem can be safely ignored.
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
phantom bang exclamation mark
Properties

Article ID: 883253 - Last Review: 05/09/2005 16:38:35 - Revision: 2.2

  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
  • kbnofix kbbug kberrmsg kbtshoot KB883253
Feedback