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Disk error causes a program to crash in Windows XP, Windows Server 2003, or Windows Vista

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

SYMPTOMS
When you use a Windows-based program, the program crashes, and you receive the following error message:
Program_name has encountered a problem and needs to close.
We are sorry for the inconvenience. If you were in the middle of something, the information you were working on might be lost.
Please tell Microsoft about this problem. We have created an error report that you can send to help us improve Program_name. We will treat this report as confidential and anonymous.
To see what data this error report contains, click here.
CAUSE
This problem may be a sign of hard-disk damage. When a file resides on a damaged area of the hard disk, Windows cannot access the file. When this occurs, the program crashes.
THINGS TO TRY
Hard-disk damage is not fixable, but sometimes you can work around the problem. To try to work around the problem, follow these steps:

Step 1: Restart your computer

When you restart your computer, Windows will automatically check your disk for errors, and Windows will try to recover any files that are located on damaged areas on the disk.

If the problem persists after you restart your computer, try Step 2.

Step 2: Scan your hard disk for errors

Run the Chkdsk.exe program to try to recover files from any damaged areas of the disk. To do this, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK. A Command Prompt window opens.
  2. Type chkdsk /r, and then press ENTER.

    You are prompted to schedule Chkdsk to run when the computer restarts.
  3. Press Y, and then press ENTER.
  4. Restart your computer. During startup, Windows will scan your disk for errors, and Windows will try to recover any files that are located on damaged areas on the disk.
If the problem persists after Windows starts, try Step 3.

Step 3: Contact your hardware manufacturer

If Steps 1 and 2 did not resolve the problem, your best bet may be to contact the manufacturer of your computer or your hard disk. The manufacturer may have a utility that you can use to perform a more detailed scan for damaged areas of the disk. However, be aware that the damage to your hard disk may be serious. Sometimes this means that your only solution is to replace your hard disk.

More information for advanced users

The following error signature applies to the error message that is mentioned in the "Symptoms" section.

EventTypeNameNTStatusCode
InPageError c000009c or C0000185 or C0000102 or C000003F or 00000002 or 00000003


Additionally, an event may be logged with an ID of 1005 that lists the file that is unreadable.
winxp winxpsp1 windowsxpsp1 winxpsp2 windowsxpsp2 bad block bad sector
Properties

Article ID: 884070 - Last Review: 04/29/2008 20:09:29 - Revision: 4.1

Microsoft Windows Server 2003, Standard Edition (32-bit x86), Microsoft Windows Server 2003, Enterprise Edition (32-bit x86), Microsoft Windows Server 2003, Web Edition, Microsoft Windows XP Home Edition, Microsoft Windows XP Professional, Microsoft Windows XP Media Center Edition, Microsoft Windows XP Tablet PC Edition, Windows Vista Business, Windows Vista Enterprise, Windows Vista Home Basic, Windows Vista Home Premium, Windows Vista Ultimate

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