You are currently offline, waiting for your internet to reconnect

The Winlogon.exe system process quits without unloading the user profile when the screen saver starts on a Windows 2000 Terminal Server at the same time that you log off from a Terminal Services session

SYMPTOMS
Consider the following scenario. The screen saver starts on a Windows 2000 Terminal Server at the same time that you log off from a Terminal Services session. The Winlogon.exe system process then quits without unloading the user profile. Additionally, if you do not restart the computer for a while, the computer becomes unresponsive.
CAUSE
This problem occurs because the secure attention sequence (SAS) request for the screen saver is not ignored when the screen saver starts at the same time that you log off from a Terminal Services session. The Winlogon.exe system process does not then continue to log off, does not call the UnloadUserProfile() function, and quits without unloading the user profile.
RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name   -----------------------------------------------------------   17-Jun-2004  23:05  5.0.2195.6951      46,352  Basesrv.dll         21-Sep-2003  00:45  5.0.2195.6824     236,304  Cmd.exe             17-Jun-2004  23:05  5.0.2195.6945     231,184  Gdi32.dll           17-Jun-2004  23:05  5.0.2195.6946     712,464  Kernel32.dll        24-Mar-2004  02:17  5.0.2195.6898      37,136  Mf3216.dll          24-Mar-2004  02:17  5.0.2195.6824      54,544  Mpr.dll             17-Jun-2004  23:05  5.0.2195.6928     335,120  Msgina.dll          24-Mar-2004  02:17  5.0.2195.6892      90,264  Rdpwd.sys   07-Feb-2005  05:35  5.0.2195.7026   6,301,696  Sp3res.dll          29-Dec-2004  09:14  5.0.2195.7017     380,688  User32.dll          05-Aug-2003  22:14  5.0.2195.6794     385,808  Userenv.dll         24-Dec-2004  17:23  5.0.2195.7013   1,633,616  Win32k.sys   15-Feb-2005  07:06  5.0.2195.7031     184,592  Winlogon.exe        17-Jun-2004  23:05  5.0.2195.6946     244,496  Winsrv.dll          17-Jun-2004  23:05  5.0.2195.6946     712,464  Kernel32.dll        24-Dec-2004  17:23  5.0.2195.7013   1,633,616  Win32k.sys   17-Jun-2004  23:05  5.0.2195.6946     244,496  Winsrv.dll  
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
MORE INFORMATION
For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Properties

Article ID: 893104 - Last Review: 10/09/2011 13:57:00 - Revision: 2.0

  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
  • kbautohotfix kbbug kbfix kbhotfixserver kbqfe KB893104
Feedback