FIX: You receive a "SQL Server does not exist or access denied" error message when you try to view tracked policy execution events in the Health and Activity Tracking tool

This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
In Microsoft BizTalk Server 2004, when you try to view tracked policy execution events in the Health and Activity Tracking (HAT) tool, you may receive the following error message:
SQL Server does not exist or access denied.
This problem occurs when the BizTalk Server databases are located in a named instance of Microsoft SQL Server.
CAUSE
This problem occurs because a bug in the HAT tool prevents BizTalk Server from correctly connecting to a named instance of SQL Server.
RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have BizTalk Server 2004 Service Pack 1 (SP1) installed on the computer to apply this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
888751 How to obtain the latest BizTalk Server 2004 service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size       File name   -----------------------------------------------------------------------------   02-Jun-2005  17:44                172,408  Bts_tracking_logic.sql   23-Jun-2005  21:49  3.0.6138.0  1,601,536  Microsoft.biztalk.brmacontrols.dll   02-Jun-2005  17:23                 25,377  Resultsutil.js   22-Jun-2005  15:35                  7,484  Rulesagendaupdates.htm   22-Jun-2005  15:35                  8,816  Rulesconditionsevaluated.htm   22-Jun-2005  15:35                  3,757  Rulesdefndetails.htm   22-Jun-2005  15:35                  6,234  Rulesfactdetails.htm   22-Jun-2005  15:35                  7,639  Rulesfiringdetails.htm   22-Jun-2005  15:35                  6,338  Rulestechdetails.htm   22-Jun-2005  15:35                  5,605  Rulestrackingtoa.htm   23-Jun-2005  21:07                 24,571  Toa.htm
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
MORE INFORMATION
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
BTS2004
Properties

Article ID: 902397 - Last Review: 01/17/2015 11:09:24 - Revision: 1.5

  • Microsoft BizTalk Server 2004 Enterprise Edition
  • Microsoft BizTalk Server 2004 Standard Edition
  • Microsoft BizTalk Server 2004 Developer Edition
  • Microsoft BizTalk Server 2004 Partner Edition
  • kbnosurvey kbarchive kbautohotfix kbbiztalk2004sp2fix kbhotfixserver kbbiztalk2004-2006swept kbbtshat kbqfe kbbug kbfix kbprb KB902397
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