The totals of intersecting calculations in Excel are incorrect after you export a report from Microsoft FRx to Excel

This article has been archived. It is offered "as is" and will no longer be updated.
Microsoft Business Solutions-Axapta 3.0 is now part of Microsoft Dynamics AX 3.0. All references to Microsoft Business Solutions-Axapta and Microsoft Axapta pertain to Microsoft Dynamics AX.
Symptoms
Consider the following scenario:
  • From Microsoft Business Solutions - FRx, you export a report that has intersecting calculations to Microsoft Excel.
  • The Calculation Priority option is set to Calculate Rows First.
  • The Export Formulas worksheet option is turned on.
In this scenario, the totals of the intersecting calculations are incorrect in Excel.

In the Microsoft FRx DrillDown Viewer, the intersecting totals are correct.
Resolution
To resolve this problem, obtain the latest service pack for Microsoft FRx 6.7. For more information, visit one of the following Microsoft Web sites, depending on whether you are a partner or a customer:
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft FRx 6.7 Service Pack 4.
Workaround
To work around this problem, turn off the Export Formulas worksheet option. The correct totals will be exported. However, no formulas will be exported. Therefore, you have to manually add the formulas in Excel.
More information

Steps to reproduce the problem

  1. Click Start, click All Programs, click FRx 6.7, and then click Report Designer.
  2. On the File menu, click New, and then click Row.
  3. Create a row format with two GL rows and a TOT row that totals the two GL rows.
  4. On the File menu, click Save, and then type a name for the row.
  5. On the File menu, click New, and then click Column.
  6. Create a column format with a DESC column, two GL columns, and a CALC column that divides one GL column by the other.
  7. On the File menu, click Save, and then name the new column.
  8. On the File menu, click New, and then click Catalog.
  9. Create your catalog by using the row and column formats that you created in steps 2 through 7.
  10. Click the Report Options tab, and then click the Advanced tab. For the Calculation Priority setting, click Calculate Rows First.
  11. Click the Output tab, and then click the Output Options tab. In the output list, click DrillDown Viewer (Enhanced XML).
  12. When the DrillDown Viewer opens, note the correct value in column D.
  13. On the File menu, click Export, click Worksheet Files, and then click Excel via OLE.
  14. On the File menu, click Save, and then type a name for the new file.
  15. In the Export Selection window, click to select the following check boxes, and then click OK:
    • Current Selection
    • Activate Workbook
    • Export Formulas
    The Excel worksheet opens, and the intersecting totals are incorrect.
Properties

Article ID: 902625 - Last Review: 01/14/2015 07:10:19 - Revision: 5.0

  • Microsoft Business Solutions for Analytics–FRx 6.7 Desktop
  • Microsoft Business Solutions–Great Plains 8.0
  • Microsoft Business Solutions–Great Plains 7.5
  • Microsoft Business Solutions–Solomon 6.0
  • Microsoft Dynamics AX 3.0
  • kbnosurvey kbarchive kbmbsmigrate kbbug kbsolomonfrx kbsmallbusinessfinancialsfrx kbgreatplainsfrx kbaxaptafrx KB902625
Feedback