An external serial modem does not return to autoanswer mode and incoming connections do not succeed after you turn off and then turn on the modem in Windows Server 2003 SP1

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

This article has been archived. It is offered "as is" and will no longer be updated.
Symptoms
On a computer that is running Microsoft Windows Server 2003 with Service Pack 1 (SP 1), an external serial modem does not return to autoanswer mode after you turn off and then turn on the modem. Incoming connections do not succeed.

Note This problem does not occur after you turn off and then turn on the computer.
Cause
This problem occurs because of a race condition in the Windows Telephony API (TAPI). A race condition occurs when a resource is accessed by two or more threads at the same time.
Resolution

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Server 2003 Service Pack 1 (SP1) installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit versions
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rastapi.dll5.2.3790.252063,48831-Aug-200503:15x86SP1SP1QFE
Unimdmat.dll5.2.3790.252075,26431-Aug-200503:15x86SP1SP1QFE
Windows Server 2003, Enterprise Edition for Itanium-based Systems
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rastapi.dll5.2.3790.2520158,72031-Aug-200504:40IA-64SP1SP1QFE
Unimdmat.dll5.2.3790.2520189,95231-Aug-200504:40IA-64SP1SP1QFE
Wrastapi.dll5.2.3790.252063,48831-Aug-200504:40x86SP1WOW
Wunimdmat.dll5.2.3790.252075,26431-Aug-200504:40x86SP1WOW
Windows Server 2003, Enterprise Edition for x64-based Systems
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Rastapi.dll5.2.3790.252085,50431-Aug-200504:40x64SP1SP1QFE
Unimdmat.dll5.2.3790.2520101,37631-Aug-200504:40x64SP1SP1QFE
Wrastapi.dll5.2.3790.252063,48831-Aug-200504:40x86SP1WOW
Wunimdmat.dll5.2.3790.252075,26431-Aug-200504:40x86SP1WOW
Workaround
To work around this problem, restart the Routing and Remote Access service.
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.
More information
For more information about the terminology that is used in this article, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
auto-answer switch
Properties

Article ID: 906278 - Last Review: 01/15/2015 14:57:25 - Revision: 5.0

  • Microsoft Windows Server 2003 Service Pack 1
  • kbnosurvey kbarchive kbautohotfix kbwinserv2003sp2fix kbqfe kbHotfixServer kbbug kbfix KB906278
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