You are currently offline, waiting for your internet to reconnect

FIX: Windows Installer tries to repair an application when the application calls the CoRegisterClassObject function in Windows Server 2003

SYMPTOMS
When an application calls the CoRegisterClassObject function, Microsoft Windows Installer tries to repair the application. This problem occurs when the application does not have to be repaired.

Consider the following scenario:
  • On a computer that is running Microsoft Windows Server 2003, Microsoft Windows Installer installs an application.
  • The application is a resilient application.
  • The application calls the CoRegisterClassObject function.
In this scenario, Windows Installer tries to repair the application.
CAUSE
When the application calls the CoRegisterClassObject function, the call impersonates the Network Service account. When Windows Installer components have not been assigned the Read permission to the Network Service account, resiliency causes Windows Installer to try to repair the application.
RESOLUTION

Windows Server 2003

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 How to obtain the latest service pack for Windows Server 2003

Hotfix information

Restart information
You must restart the computer after you apply this hotfix.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.

Hotfix 32-bit version
File nameFile versionFile sizeDateTimePlatformSP requirement
Ole32.dll5.2.3790.26391,247,74416-Feb-200604:45x86SP1
Rpcss.dll5.2.3790.2639421,88816-Feb-200604:45x86SP1
Hotfix 64-bit version
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.26392,547,20016-Feb-200605:04x64SP1Not applicable
Rpcss.dll5.2.3790.2639698,36816-Feb-200605:04x64SP1Not applicable
Hotfix 64-bit version for Itanium processors
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Ole32.dll5.2.3790.26393,999,74416-Feb-200605:05IA-64SP1Not applicable
Rpcss.dll5.2.3790.2639859,64816-Feb-200605:05IA-64SP1Not applicable
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Server 2003 Service Pack 2.
MORE INFORMATION
In Windows Server 2003 and in Windows XP SP2, the Remote Procedure Call service runs under the Network Service account. In versions of Microsoft Windows earlier than Windows Server 2003 and Windows XP SP2, the Remote Procedure Call service runs under the SYSTEM account.

In Windows Server 2003 and in Windows XP SP2, calls to Windows Installer do not impersonate the SYSTEM account. Instead, calls to Windows Installer impersonate the Network Service account.

For more information about resiliency, visit the following Microsoft Developer Network (MSDN) Web site: For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Properties

Article ID: 915030 - Last Review: 10/09/2011 06:03:00 - Revision: 4.0

  • Microsoft Windows Installer 3.1
  • Microsoft Windows Installer 3.0
  • kbautohotfix kbwinserv2003sp2fix kbbug kbfix kbtshoot kbHotfixServer kbqfe KB915030
Feedback