You are currently offline, waiting for your internet to reconnect

Text takes longer than expected to appear on the screen when you type in an Office program

Support for Office 2003 has ended

Microsoft ended support for Office 2003 on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
When you type in one of the Microsoft Office programs that are listed in the "Applies to" section, the text takes longer than expected to appear on the screen.
CAUSE
This problem may occur if one or more of the following conditions are true:
  • A third-party program that conflicts with the Office programs is running in the background.
  • Your computer is infected with a virus.
  • The background spelling and grammar checker is turned on.
  • The temporary cache is full.
  • The computer is processing memory-intensive files over a slow network connection. For example, this problem may occur if the computer is processing a large Microsoft PowerPoint presentation that has lots of embedded objects.
WORKAROUND
To work around this problem, use the following methods as appropriate for your situation.

Method 1: Start the computer in safe mode

To determine whether the slow performance occurs because of a third-party program that is installed on the computer, start the computer in safe mode. To do this, follow these steps.

Note Because there are several versions of Microsoft Windows, the following steps may be different on your computer. If they are, see your product documentation to complete these steps.
  1. Restart the computer.
  2. When the computer starts, press F8 to display the Windows Advanced Options Menu.

    Note If you do not see this menu, and the computer starts to load Windows, go back to step 1.
  3. In the Windows Advanced Options Menu, select Safe Mode, and then press ENTER.
  4. When the start process is complete, log on to Windows. Then, start the Office program in which you experience the problem that is described in the "Symptoms" section.
  5. Run the Office program for several minutes. Additionally, open and change some files in the Office program, and then save the files.
If starting the computer in safe mode resolves the problem, it is likely that a third-party program is creating a conflict with one of the Office programs that are listed in the "Applies to" section. To determine which program causes the problem, start the computer by performing a clean boot. For more information about how to perform a clean boot, click the following article numbers to view the articles in the Microsoft Knowledge Base:
310353 How to perform a clean boot in Windows XP
281770 How to perform clean-boot troubleshooting for Windows 2000

Method 2: Install antivirus and antispyware software

For a long-term solution to macro viruses, install antivirus software that is designed specifically to detect macro viruses. For more information about antivirus software, click the following article number to view the article in the Microsoft Knowledge Base:
49500 List of antivirus software vendors

Method 3: Turn off the background spelling and grammar checker

When you type a space or press ENTER, the background spelling and grammar checker examines what you typed. The spelling checker flags misspelled words by using a red wavy underline. The grammar checker flags grammatical errors by using a green wavy underline. If the spelling files or grammar files are damaged, you may receive an error message when you type.

To turn off the background spelling and grammar checker, follow these steps.
  • Microsoft Word
    1. Open a Word document.
    2. On the Tools menu, click Options.
    3. In the Options dialog box, click the Spelling & Grammar tab.
    4. Click to clear the Check spelling as you type check box and the Check grammar as you type check box. Then, click OK.
  • Microsoft PowerPoint
    1. Open a PowerPoint presentation.
    2. On the Tools menu, click Options.
    3. In the Options dialog box, click the Spelling and Style tab.
    4. Click to clear the Check spelling as you type check box, and then click OK.
  • Microsoft Publisher
    1. Open a Publisher file.
    2. On the Tools menu, point to Spelling, and then click Spelling Options.
    3. In the Spelling Options dialog box, click to clear the Check spelling as you type check box, and then click OK.

Method 4: Delete unnecessary temporary files

To delete temporary Internet files and the history cache, follow these steps:
  1. Start Microsoft Internet Explorer.
  2. On the Tools menu, click Internet Options.
  3. On the General tab, click Delete Files under Temporary Internet files.
  4. Click to select the Delete all offline content check box, and then click OK.
  5. Under History, click Clear History, and then click Yes when you are prompted for confirmation.
To delete the contents of the Temp folder, follow these steps:
  1. Click Start, click Run, type %temp%, and then click OK.
  2. Delete the contents of this folder. If any of the items are important and should not be deleted, move the items to another folder.
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Properties

Article ID: 920629 - Last Review: 12/09/2015 05:59:48 - Revision: 3.0

Microsoft Word 2002, Microsoft Word 2000, Microsoft Office PowerPoint 2003, Microsoft PowerPoint 2002 Standard Edition, Microsoft PowerPoint 2000 Standard Edition, Microsoft Office Publisher 2003, Microsoft Publisher 2002 Standard Edition, Microsoft Publisher 2000 Standard Edition

  • kbnosurvey kbarchive kbperformance kbexpertisebeginner kbtshoot kbprb KB920629
Feedback