Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

On a client computer that is running Windows XP or Windows Server 2003, you try to access shared files on a Distributed File System (DFS) server in a domain environment. However, Windows Explorer may stop responding in this situation. Additionally, CPU usage is very high on the primary domain controller (PDC). Specifically, the Dfssvc.exe process consumes most of the CPU resources.

Note This issue may occur after the shadow-copy feature is enabled on the DFS server.

Cause

This issue may occur because of an error in the Twext.dll file. When this error occurs, the client computer sends many referral requests to the DFS server after you try to access shared files.

Resolution

Windows XP hotfix information

To resolve this problem for Windows XP Service Pack 2, install the hotfix that is described in the following Microsoft Knowledge Base article:

941133 The Properties dialog box of a DFS share takes several minutes to appear on a Windows XP-based client computer

Windows Server 2003 update information

Install this update to resolve the issue in which Windows Explorer stops responding on client computers that are running Windows XP Professional or Windows Server 2003 in a domain environment where CPU usage on the primary domain controller is high.


The following files are available for download from the Microsoft Download Center:

DownloadDownload the Update for Windows Server 2003 (KB925066) package now.

DownloadDownload the Update for Windows Server 2003 x64 Edition (KB925066) package now.

DownloadDownload the Update for Windows Server 2003 for Itanium-based Systems (KB925066) package now.

DownloadDownload the Update for Windows XP x64 Edition (KB925066) package now.

Release Date: October 23, 2007

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:

119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart your computer after you apply this update.

Update replacement information

This update does not replace any other updates.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

Windows Server 2003, x86-based versions

File name

File version

File size

Date

Time

Platform

SP requirement

Service branch

Twext.dll

6.0.3790.2985

82,944

07-Aug-2007

10:16

x86

SP1

SP1QFE

Twext.dll

6.0.3790.4127

84,992

07-Aug-2007

11:08

x86

SP2

SP2QFE

Windows Server 2003, x64-based versions

File name

File version

File size

Date

Time

Platform

SP requirement

Service branch

Twext.dll

6.0.3790.2985

112,640

06-Aug-2007

21:17

x64

SP1

SP1QFE

Wtwext.dll

6.0.3790.2985

82,944

06-Aug-2007

21:17

x86

SP1

WOW

Twext.dll

6.0.3790.4127

118,784

06-Aug-2007

21:20

x64

SP2

SP2QFE

Wtwext.dll

6.0.3790.4127

84,992

06-Aug-2007

21:20

x86

SP2

WOW

Windows Server 2003, Enterprise Edition for Itanium-based Systems

File name

File version

File size

Date

Time

Platform

SP requirement

Service branch

Twext.dll

6.0.3790.2985

199,168

06-Aug-2007

21:17

IA-64

SP1

SP1QFE

Wtwext.dll

6.0.3790.2985

82,944

06-Aug-2007

21:17

x86

SP1

WOW

Twext.dll

6.0.3790.4127

207,360

06-Aug-2007

21:21

IA-64

SP2

SP2QFE

Wtwext.dll

6.0.3790.4127

84,992

06-Aug-2007

21:21

x86

SP2

WOW

Note After you apply this update on the client computer, the client computer will not send out redundant referral requests to the DFS server.

Workaround

To work around this issue, disable the shadow-copy feature on the DFS server. To do this, follow these steps:

  1. Right-click the volume on which you want to disable the shadow-copy feature, and then click Properties.

  2. On the Shadow Copies tab, select the volume on which you want to disable the shadow-copy feature, click Disable, and then click OK two times.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

References

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

888603 Update to disable Volume Shadow Copy Service restore options on Terminal Server client computers that are running Windows Server 2003 or Windows XP

For more information, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×