An access violation occurs, and the installation process stops responding for Windows XP SP2, Windows Server 2003 SP1 and SP2 when the installation process tries to migrate hotfixes

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

This article has been archived. It is offered "as is" and will no longer be updated.
Symptoms
When you install the following Windows operating systems, the installation process successfully updates the system files:
  • Microsoft Windows XP Service Pack 2 (SP2)
  • Microsoft Windows Server 2003 Service Pack 1 (SP1)
  • Microsoft Windows Server 2003 Service Pack 2 (SP2)
However, an access violation occurs, and the installation process stops responding when it tries to migrate hotfixes. When the access violation is generated, the following message might be recorded in the application log:
Date(A):  yyyy/mm/dd  Source(S): Application ErrorTime(M):  hh:mm:ss  Rank(R): (100)Kind(E): error Event ID(I): 1000User(U): N/AComputer(O): machineError Application: update.exe, Version: x.x.x.x, Error Module: ntdll.dll, Version: x.x.x.x. Error Address: 0x00000000.


For detailed information, please refer to the help and support center: http://www.microsoft.com/technet/support/ee/ee_basic.aspx

Windows XP log file information

When this problem occurs on a Windows XP-based computer, information that resembles the following is logged in the Svcpack.log file:
2933.438: MigrateHotfix: Hotfix KB924496 successfully migrated2933.438: MigrateHotfixes: Return code: 30102933.529: Files To Attach C:\WINDOWS\svcpack.log C:\WINDOWS\svcpack.log 2934.861: Waiting For watson First time ...2935.562: Waiting For watson First time ...2935.702: Waiting For watson First time ...2942.361: Waiting For watson First time ...2949.031: Waiting For watson First time ...2955.700: Waiting For watson First time ...2962.370: Waiting For watson First time ...2969.040: Waiting For watson First time ...2971.553: Waiting For watson First time ...

Windows Server 2003 log file information

When this problem occurs on a Windows Server 2003-based computer, information that resembles the following is logged in the Svcpack.log file:
1817.391: MigrateHotfix: Hotfix KB928255 successfully migrated1817.391: MigrateHotfixes: Return code: 30101817.391: MigrateHotfix: Migrating hotfix KB9288431817.391: Migrating QFE KB928843 with command line: update.exe -Z -Q -B:sp1rtm1828.328: MigrateHotfix: Hotfix KB928843 successfully migrated1828.328: MigrateHotfixes: Return code: 01828.328: MigrateHotfix: Migrating hotfix KB9299691828.328: Migrating QFE KB929969 with command line: update.exe -Z -Q -B:sp1rtm1839.235: MigrateHotfix: Hotfix KB929969 successfully migrated1839.235: MigrateHotfixes: Return code: 01839.235: MigrateHotfix: Migrating hotfix KB9318361839.235: Migrating QFE KB931836 with command line: update.exe -Z -Q -B:sp1rtm1841.078: Update.exe failed 1603.1841.078: MigrateHotfixes: Migration of KB931836 failed
Cause
This problem occurs because a buffer that is used to store the hotfix migration list is not large enough. This problem occurs when lots of software updates have been installed. Additionally, these software updates were released after Windows XP Service Pack 1 or Windows Server 2003 were released. These software updates include the updates that you obtained from the following sources:
  • Windows Update
  • Hotfixes that you received from Microsoft Customer Support Services
  • Any updates that were installed by using a Microsoft Windows Server Update Services (WSUS) server
Resolution
To resolve the problem, apply the update that is described in this article before you install Windows XP Service Pack 2 or before you install a service pack for Windows Server 2003.

Update information

Windows XP

The following file is available for download from the Microsoft Download Center:

DownloadDownload the Update for Windows XP (KB928595) package now.

Release Date: July 24, 2007

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this update.

Update replacement information

This update does not replace any other hotfixes.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft Windows XP Service Pack 2
File nameFile versionFile sizeDateTimeSP requirementService branch
Acspecfc.dll5.1.2600.3072245,24825-Jan-200712:24SP2SP2GDR
Acadproc.dll5.1.2600.307239,42425-Jan-200712:36SP2SP2QFE
Acspecfc.dll5.1.2600.3072245,24825-Jan-200712:36SPSP2QFE

Windows Server 2003

The following file is available for download from the Microsoft Download Center:

DownloadDownload the Update for Windows Server 2003 (KB928595) package now.

Release Date: July 24, 2007

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this update.

Update replacement information

This update does not replace any other hotfixes.

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft Windows Server 2003 Service Pack 1
File nameFile versionFile sizeDateTimeSP requirementService branch
Acspecfc.dll5.2.3790.2953266,75211-Jun-200715:51SP1SP1GDR
Acspecfc.dll5.2.3790.2953266,75211-Jun-200715:56SP1SP1QFE
Acspecfc.dll5.2.3790.4097266,75211-Jun-200716:43SP2SP2GDR
Acspecfc.dll5.2.3790.4097266,75211-Jun-200716:32SP2SP2QFE
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. 
More information
For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Dr. Watson [ReverseMigrate]
Properties

Article ID: 928595 - Last Review: 01/16/2015 16:58:16 - Revision: 10.0

  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • kbnosurvey kbarchive atdownload kbexpertisebeginner kbfix kbbug kbqfe KB928595
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