Error message when you upgrade SoftGrid Client: "A later version of 'SoftGrid for Windows Desktops or Terminal Servers' is already installed"

This article has been archived. It is offered "as is" and will no longer be updated.
SUMMARY
When you upgrade Microsoft SoftGrid Client, the operation fails. In addition, you receive one of the following error messages:
A later version of 'SoftGrid for Windows Desktops' is already installed on this machine. The setup cannot continue.

A later version of 'SoftGrid for Terminal Servers' is already installed on this machine. The setup cannot continue.
CAUSE
This problem occurs if you try to upgrade SoftGrid Client 3.2.x by using the .exe file or the .msi file.You must use the .msp file to upgrade SoftGrid Client 3.2.x. You can perform the upgrade by manually executing the file or by using command-line parameters.
MORE INFORMATION
For example, you can use the following command to upgrade SoftGrid Client 3.2.x:
msiexec.exe /p "softgrid-xx-HFxxxxxxxxxx.msp" REINSTALL=ALL REINSTALLMODE=omus /qn
You can upgrade SoftGrid Client 3.1.x by using the .exe file or the .msi file.

For more information about SoftGrid Client command-line parameters, click the following article number to view the article in the Microsoft Knowledge Base:
930848 SoftGrid Client 3.x command-line installation parameters
Properties

Article ID: 931102 - Last Review: 01/15/2015 01:12:30 - Revision: 1.2

  • Microsoft SoftGrid for Terminal Services
  • Microsoft SoftGrid for Windows Desktops
  • kbnosurvey kbarchive kbexpertiseinter kbtshoot KB931102
Feedback