Some applications do not run successfully when they are installed to drive Q in SoftGrid

This article has been archived. It is offered "as is" and will no longer be updated.
SYMPTOMS
Some applications do not run successfully when they are installed to drive Q in SoftGrid. However, these applications do run successfully when they are installed to other drives.
CAUSE
This issue occurs because the parser searches the virtual registry for the “Q:” and “q:” strings. The parser then replaces these strings with "%SFT_MNT%." Sometimes, the parser replaces strings that have “Q:” and “q:” that are not path-related. This process can cause the application to fail.
WORKAROUND
To work around this issue, install the application to a different drive letter. You can use the Virtual Registry Editor to search for “Q:” and “q:” to confirm that this is the reason that the application does not run successfully.

The application may also have hard-coded paths in the source code or in various files on disk. These paths may point to a specific drive letter. To work around this issue, install the application to the correct drive letter.
Properties

Article ID: 931249 - Last Review: 01/14/2015 12:39:21 - Revision: 2.0

Microsoft SoftGrid for Terminal Services, Microsoft SoftGrid for Windows Desktops

  • kbnosurvey kbarchive kbtshoot kbexpertiseinter KB931249
Feedback
ERROR: at System.Diagnostics.Process.Kill() at Microsoft.Support.SEOInfrastructureService.PhantomJS.PhantomJSRunner.WaitForExit(Process process, Int32 waitTime, StringBuilder dataBuilder, Boolean isTotalProcessTimeout)