No results are returned in the search results when you search for people by site membership in SharePoint Server 2007

This article has been archived. It is offered "as is" and will no longer be updated.
You connect to the Search Center in Microsoft Office SharePoint Server 2007. Then, you click the People tab, click Search Options, and then search for people by site membership. However, no results are returned in the search results.
This problem occurs because the managed name of the QuickLinks property in the People Search Box Web Part is incorrectly set to QuickLinks. The managed name of the QuickLinks property should be set to Memberships.
To work around this problem, set the QuickLinks property of the People Search Box Web Part to use the correct managed name. To do this, follow these steps:
  1. Connect to the Search Center, and then click the People tab.
  2. Click Site Actions, and then click Edit Page.
  3. In the People Search Box Web Part, click edit, and then click Modify Shared Web Part.
  4. Under People Search Box, expand Miscellaneous.
  5. Click in the Properties box, and then click the ... button.
  6. Scroll to the bottom of the Text Entry -- Web Page Dialog dialog box, and then locate the following line.
    <Property Name="QuickLinks" ManagedName="QuickLinks" ProfileURI="urn:schemas-microsoft-com:sharepoint:portal:profile:QuickLinks"/></Properties>
    Replace the line with the following line.
    <Property Name="QuickLinks" ManagedName="Memberships" ProfileURI="urn:schemas-microsoft-com:sharepoint:portal:profile:QuickLinks"/></Properties>
  7. Click OK two times.
  8. Click Publish to publish the page.
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Article ID: 935196 - Last Review: 01/16/2015 02:17:44 - Revision: 1.0

  • Microsoft Office SharePoint Server 2007
  • kbnosurvey kbarchive kbpending kbtshoot kbbug kbexpertiseinter KB935196