You may be prompted to restart the computer after you install the 64-bit version of SQL Server 2005 Service Pack 2 even if the Setup program does not report that some components are locked

Extended support for SQL Server 2005 ended on April 12, 2016

If you are still running SQL Server 2005, you will no longer receive security updates and technical support. We recommend upgrading to SQL Server 2014 and Azure SQL Database to achieve breakthrough performance, maintain security and compliance, and optimize your data platform infrastructure. Learn more about the options for upgrading from SQL Server 2005 to a supported version here.

Bug #: 494490 (SQLBUDT)
SYMPTOMS
You try to install the 64-bit version of Microsoft SQL Server 2005 Service Pack 2 (SP2) on a computer that has a 64-bit edition of SQL Server 2005 installed. When the installation process starts, the Setup program may not detect that 32-bit components are locked. The 32-bit components are installed together with the 64-bit edition of SQL Server 2005. Therefore, the Setup program does not report these components in the Files in Use dialog box. However, you may still be prompted to restart the computer when the installation process ends.
CAUSE
This problem occurs because the 64-bit Setup program cannot detect if a 32-bit application is locking 32-bit SQL Server components.
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
Properties

Article ID: 937684 - Last Review: 11/20/2007 17:47:15 - Revision: 1.3

Microsoft SQL Server 2005 Developer Edition, Microsoft SQL Server 2005 Enterprise Edition, Microsoft SQL Server 2005 Standard Edition, Microsoft SQL Server 2005 Standard X64 Edition, Microsoft SQL Server 2005 Standard Edition for Itanium-based Systems, Microsoft SQL Server 2005 Enterprise X64 Edition, Microsoft SQL Server 2005 Enterprise Edition for Itanium-based Systems

  • kbtshoot kbexpertiseadvanced kbsql2005setup kbprb KB937684
Feedback