You are currently offline, waiting for your internet to reconnect

Netlogon event ID 5719 or Group Policy event 1129 is logged when you start a domain member

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Support for Windows Server 2003 ended on July 14, 2015

Microsoft ended support for Windows Server 2003 on July 14, 2015. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

Symptoms
Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.

Consider the following scenario:
  • You have a computer that's running one of the operating systems that's mentioned in the “Applies to” section.
  • The computer is joined to a domain.
  • One of the following conditions is true:
    • The computer has a Gigabit network adapter installed.
    • You secure the network access by using Network Access Protection (NAP), network authentication (by using 802.1x), or another method.
In this scenario, the following event is logged in the System log when you start the computer in every version of Windows up to and including Windows 8.1:

Event Type: Error
Event Source: NETLOGON
Event Category: None
Event ID: 5719
Description: No Domain Controller is available for domain <domain name> due to the following:
There are currently no logon servers available to service the logon request.
Make sure that the computer is connected to the network and try again.
If the problem persists, contact your domain administrator.

In Windows 10 and newer versions, event 5719 is no longer logged in this situation. Instead, the following lines are recorded in Netlogon.log:
[CRITICAL] [960] CONTOSO: NlSessionSetup: Session setup: cannot pick trusted DC[SESSION] [960] No IP addresses present, skipping No DC event log
After this occurs, the computer is assigned an IP address:
[SESSION] [960] V6 Winsock Addrs: fe80::5faf:632a:f22c:644a%2 (1) V6WinsockPnpAddresses List used to be empty.[SESSION] [960] Winsock Addrs: 10.1.1.80 (1) List used to be empty.
On Windows 10 and later versions, you will see only events by components, depending on the Domain Controller connectivity (such as Group Policy):

Log Name: System
Source: Microsoft-Windows-GroupPolicy
Event ID: 1129
Level: Error
Description:
The processing of Group Policy failed because of lack of network connectivity to a domain controller. This may be a transient condition. A success message would be generated once the machine gets connected to the domain controller and Group Policy has successfully processed. If you do not see a success message for several hours, then contact your administrator.

The following is recorded in the group policy debug log:
CGPApplicationService::MachinePolicyStartedWaitingOnNetwork.CGPMachineStartupConnectivity::CalculateWaitTimeoutFromHistory: Average is 388.CGPMachineStartupConnectivity::CalculateWaitTimeoutFromHistory: Current is -1.CGPMachineStartupConnectivity::CalculateWaitTimeoutFromHistory: Taking min of 776 and 30000.Waiting for SamSs with timeout 776 …NlaQueryNetSignatures returned 1 networksNSI Information (Network GUID)  : {395DB3C8-CE45-11E5-9739-806E6F6E6963}NSI Information (CompartmentId) : 1NSI Information (SiteId)        : 134217728NSI Information (Network Name)  : NlaGetIntranetCapability failed with 0x15There is no domain compartmentProcessGPOs(Machine): MyGetUserName failed with 1355.Opened query for NLA successfullyNlaGetIntranetCapability returned Not Ready error. Consider it as NOT intranet capable.…GPSVC(530.ae0) 13:32:28:728 There is no connectivityGPSVC(530.8e0) 13:32:28:728 ApplyGroupPolicy: Getting ready to create background thread GPOThread.
The first section shows the calculation for the time-out to use to bring up the network. This can be based on previous fast startups.

The second section shows that NLA fail to report a working network within the wait interval that is allowed, and group policy startup processing fails.The third section shows that the Group Policy engine starts a background procedure, and then waits for one minute after a network becomes available.
Cause
This issue may occur for any of the following reasons:
  • The Netlogon service starts before the network is ready. The network stack and adapter initialization often start at about the same time. Some network adapters and switches have link arbitration and MAC address uniqueness checks that take longer to complete than the wait time that is set for Netlogon to detect network connectivity.
  • Solutions that verify the health of the new network member delay the network connection and your ability to access domain controllers. If you have an automatic Direct Access channel connection enabled, this may also require more time to perform than Netlogon allows.
  • The 802.1X authentication process delays connections to the domain controllers.
  • The client experiences a delay to retrieve an IP address from the DHCP server. This delays the display of the network interface.
Group Policy in Windows Vista and later versions is written to negotiate the network status that has Network Location Awareness (NLA) enabled, and it waits for a network that has DC connectivity. However, Group Policy may start prematurely because of a policy application. This is especially true when the delay in finding a network alternates between startups.
Resolution
Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Resolution 1

To resolve this issue, install the most current driver for the Gigabit network adapter. Or, enable the "PortFast" option on the network switches.

Resolution 2

There is a known problem that affects DHCP client code in Windows 7. A hotfix for Windows 7 that resolves this problem is available through the following Microsoft Knowledge Base article:

2459530 Event ID 5719 and event ID 1129 may be logged when a non-Microsoft DHCP Relay Agent is used
Note This particular problem does not affect Windows 8, Windows Server 2012, or later versions of these systems.

Resolution 3

To resolve this issue, use the registry to change the related settings that affect DC connectivity. To do this, use the following methods.

Method 1

Adjust the firewall settings or IPSEC policies that are changed to allow DC connectivity. These changes are made when the client receives an IP address but requires more time to access a domain controller (for example, after a successful verification through Cisco NAC or Microsoft NPS Services).

Method 2

Configure the Netlogon registry setting to a value that is safely beyond the time that is required allow DC connectivity. Please note this is only effective if the machine already has an IP address. This applies to scenarios where a NAP solution puts the machine into a quarantine network. Use the following settings as guidelines.

Registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Netlogon\Parameters

Value Name: ExpectedDialupDelay
Data Type: REG_DWORD
Data Value is in seconds (default=0)
Data Range is between 0 and 600 seconds (10 minutes)

For more information, see the following Microsoft Knowledge Base article:

819108 Settings for minimizing periodic WAN traffic

Method 3

The IP stack tries to verify the IP address using an ARP broadcast. This delays the time that the IP takes to come online. You can set the ArpRetryCount registry entry to one (1), so the wait for uniqueness is shortened. To do this, follow these steps:
  1. Start Registry Editor.
  2. Locate and select the following subkey:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\TcpIp\Parameters\
  3. On the Edit menu, point to New, and then click DWORD Value.
  4. Type ArpRetryCount.
  5. Right-click the ArpRetryCount registry entry, and then click Modify.
  6. In the Value data box, type 1, and then click OK.

    Note The Data Range is between 0 and 3 (3 is default).
  7. Exit Registry Editor.
For more information, download the "TCP/IP Registry Values for Microsoft Windows Vista and Windows Server 2008" document from the following Microsoft Download Center website:


Method 4

Reduce the Netlogon negative cache period by changing the NegativeCachePeriod registry entry in the following subkey:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Netlogon\Parameters\NegativeCachePeriod
After you make this change, the Netlogon service does not behave as if the domain controllers are offline for 45 seconds. The event 5719 is still logged. However, the event does not cause any other significant problems. This setting allows member to try domain controllers earlier if the process failed previously.

Suggestion: Try to set a low value, such as three seconds. In LAN environments, you can use a value of 0 to turn off the negative cache.

For more information about this setting, click the following article number to go to the article in the Microsoft Knowledge Base:

819108 Settings for minimizing periodic WAN traffic

Method 5

Configure the Kerberos registry setting to a value that is safely beyond the time that is required allow DC connectivity. Use the following settings as guidelines.

Note This setting applies only to Windows XP and Windows Server 2003 or earlier versions of these systems. Windows Vista and Windows Server 2008 and later versions use a default value of 0. This value turns off User Datagram Protocol (UDP) functionality for the Kerberos client.

Registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Lsa\Kerberos\Parameters

Value name: MaxPacketSize
Data Type: REG_DWORD
Value Data: 1
Default: (depends on the system version)

For more information, click the following article number to go to the article in the Microsoft Knowledge Base:

244474 How to force Kerberos to use TCP instead of UDP in Windows

Method 6

Disable media sense for TCP/IP. To do this, add the following value to the Tcpip registry subkey:

Registry subkey:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters

Value Name: DisableDHCPMediaSense
Data Type: REG_DWORD
Value Data: 1
Value Range: Boolean (0=False, 1=True)
Default: 0 (False)

For more information, click the following article number to go to the article in the Microsoft Knowledge Base:

239924 How to disable the Media Sensing feature for TCP/IP in Windows

Method 7

Group Policy has policy settings to control the wait time for startup policy processing:
  1. Corporate LAN or WLAN:
    Policy Folder: “Computer Configuration\Administrative Templates\System\Group Policy\”Policy Name: “Specify startup policy processing wait time”
  2. External LAN or WLAN:
    Policy Folder: “Computer Configuration\Administrative Templates\System\Group Policy\”Policy Name: “Specify workplace connectivity wait time for policy processing”
The time it takes Netlogon to acquire a working IP can be the basis for the setting. For Direct Access scenarios you can measure the typical delay your user base has until the connection is established.


Method 8

If DisabledComponents registry setting is in place and has an incorrect value of 0xfffffff, either delete the key or change it to the intended value of 0xff.

Important
Internet Protocol version 6 (IPv6) is a mandatory part of Windows Vista and later versions of Windows. We do not recommend that you disable IPv6 or its components. If you do, some Windows components may not function. Additionally, system startup will be delayed for five seconds if IPv6 is disabled incorrectly by setting the  DisabledComponents registry setting to a value of 0xfffffff. The correct value is 0xff . For more information, see the "What are Microsoft's recommendations about disabling IPv6?" question in IPv6 for Microsoft Windows: Frequently Asked Questions.

More information
If you can log on to the domain without a problem, you can safely ignore event ID 5719. Because the Netlogon service may start before the network is ready, the computer may be unable to locate the logon domain controller. Therefore, event ID 5719 is logged. However, after the network is ready, the computer will try again to locate the logon domain controller. In this situation, the operation should be successful.

In a Netogon.log, entries that resemble the following may be logged:

08/24 07:47:03 [CRITICAL] <domain>: NlDiscoverDc: Cannot find DC.08/24 07:47:03 [CRITICAL] <domain>: NlSessionSetup: Session setup: cannot pick trusted DC08/24 07:47:03 [MISC] Eventlog: 5719 (1) "<domain>" 0xc000005e ...08/24 07:47:03 [SESSION] WPNG: NlSetStatusClientSession: Set connection status to c000005e...08/24 07:47:19 [SESSION] \Device\NetBT_Tcpip_{4A47AF53-40D3-4F92-ACDF-9B5E82A50E32}: Transport Added (10.0.64.232)-> Getting a proper IP address takes >15 seconds.
Similar errors might be reported by other components that require Domain Controller connectivity to function correctly. For example, the Group Policy may not be applied at system startup. In this case, startup scripts do not run. The Group Policy failures may be related to the failure of Netlogon to locate a domain controller. You can set Group Policy to be more responsive to late network connectivity arrival. 

For more information, click the following article number to go to the article in the Microsoft Knowledge Base:

2421599 Windows 7 Clients intermittently fail to apply group policy at startup
Properties

Article ID: 938449 - Last Review: 08/22/2016 22:09:00 - Revision: 14.0

Windows 10, Windows 8.1, Windows 8 Pro, Windows 8, Windows 8.1 Pro, Windows Server 2012 R2 Datacenter, Windows Server 2012 R2 Standard, Windows Server 2012 R2 Essentials, Windows Server 2012 Datacenter, Windows Server 2012 Standard, Windows Server 2012 Essentials, Windows 7 Enterprise, Windows 7 Ultimate, Windows 7 Professional, Windows Server 2008 R2 Enterprise, Windows Server 2008 R2 Standard, Windows Server 2008 Enterprise, Windows Server 2008 Standard, Windows Vista Enterprise, Windows Vista Ultimate, Windows Vista Business, Microsoft Windows XP Professional, Microsoft Windows Server 2003 Service Pack 2, Microsoft Windows 2000 Professional Edition, Microsoft Windows 2000 Advanced Server, Microsoft Windows 2000 Server, Windows 8.1 with Bing

  • kbexpertiseinter kbtshoot kbprb KB938449
Feedback
&did=1&t=">