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Custom actions fail when you install an MSI package that runs Custom Action Type 2 in the system account or in the service account on a Windows XP-based computer

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

SYMPTOMS
Custom actions fail on a Windows XP-based computer when you install an MSI package that runs Custom Action Type 2 in either of the following accounts:
  • System account
  • Service account
Additionally, if you capture the Windows Installer log, you find that error code 1721 is logged. This problem occurs if you have installed any update package that contains hotfix 909737.

Note Hotfix 909737 updates the Advapi32.dll file.
CAUSE
This problem occurs because of a regression in hotfix 909737.
RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows XP Service Pack 2 (SP2) installed on the computer.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Advapi32.dll5.1.2600.3227624,64004-Oct-200718:24x86
WORKAROUND
To work around this problem, manually install the MSI package.
STATUS
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
MORE INFORMATION
For more information about custom actions, visit the following Microsoft Web sites:For more information, click the following article number to view the article in the Microsoft Knowledge Base:
314852 How to enable Windows Installer logging in Windows XP
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Properties

Article ID: 943092 - Last Review: 12/20/2007 21:30:36 - Revision: 1.1

Microsoft Windows XP Home Edition, Microsoft Windows XP Professional

  • kbautohotfix kbfix kbexpertisebeginner kbqfe kbhotfixserver KB943092
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