Error message when WMI queries against the CIM_DataFile class after you log on to a Windows XP SP2-based computer by using a non-administrative user account: "SWbemServicesEx: Access denied"

Support for Windows XP has ended

Microsoft ended support for Windows XP on April 8, 2014. This change has affected your software updates and security options. Learn what this means for you and how to stay protected.

This article has been archived. It is offered "as is" and will no longer be updated.
Symptoms
Consider the following scenario:
  • You log on to the console session of a Windows XP Service Pack 2 (SP2)-based computer by using a non-administrative user account.
  • Windows Management Instrumentation (WMI) queries against the CIM_DataFile class. This query runs under the local system context.
In this scenario, all the WMI queries fail. Additionally, you receive an error message that resembles the following:
SWbemServicesEx: Access denied
Cause
After you log on to the console session of a Windows XP SP2-based computer by using a non-administrative user account, Windows may be unable to revert to the local system context when WMI code runs under the local system context. Therefore, the WMI code can run only under the limited permissions of the user.
Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site: Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Windows XP Service Pack 2 installed.

Restart requirement

You have to restart your computer if the Win32 provider (Cimwin32.dll) is loaded in a WMI Provider Host process (Wmiprvse.exe).

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows XP with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Cimwin32.dll5.1.2600.32481,358,33606-Nov-200706:14x86
Status
Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.
More information
For more information about the CIM_DataFile class, visit the following Microsoft Web site:For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Properties

Article ID: 943828 - Last Review: 11/02/2013 16:24:00 - Revision: 3.0

Microsoft Windows XP Service Pack 2

  • kbnosurvey kbarchive kbautohotfix kbexpertiseadvanced kbfix kbqfe kbHotfixServer KB943828
Feedback
ERROR: at System.Diagnostics.Process.Kill() at Microsoft.Support.SEOInfrastructureService.PhantomJS.PhantomJSRunner.WaitForExit(Process process, Int32 waitTime, StringBuilder dataBuilder, Boolean isTotalProcessTimeout)